Installing 10.04 to 2TB disk, does not boot

Matthias Brennwald matthias at
Mon May 17 14:04:32 UTC 2010

Dear all

I tried to install Ubuntu 10.04 to a 2TB disk. The installation itself completed without errors (not even when GRUB got installed). However, the system won't boot from the fresh install. After installation and trying to reboot into the new install I only get a message saying that the disk is not bootable. Here's a link to the machine I am using (Tranquil PC Barebones Server):

Here's what I tried so far:

1. Installation using the the Live CD. Result: won't boot.
2. Installation using alternate CD. Result: won't boot.
3. I manually formatted the disk to explicitly include a small bios_grub partition, hoping that might help to properly install GRUB2. Then repeated the install from the alternate CD. Result: won't boot.
4. I took another disk with Ubuntu already on it (160 GB, removed from another machine). Result: This boots nicely.
5. Installed to yet another disk (also 160 GB, using the alternate CD). Result: This boots nicely.

So, in summary, it looks like the problem is related to my 2TB disk.

Please note:
- The above tests were done with only one disk installed (the Tranquil PC Barebones Server will take up to 5 disks).
- This post is (sort of) a follow up to my earlier post with the subject "Cannot boot from software RAID with 2TB disks". As you can see from this follow up, it looks like the problem I described there was not (only) related to the RAID.

Any hints or ideas on how I can make this work with my 2TB disk(s) would be great!

Thanks in advance

Matthias Brennwald
Eawag, CH-8600 Dübendorf
Office Eawag BU-C08: +41 44 823 53 05
Lab Eawag LA-C76: +41 44 823 53 06
Lab ETHZ CLA A31.6: +41 632 09 36/39
matthias.brennwald at

More information about the ubuntu-users mailing list