Removable drive (usb) doesn't mount

Amedee Van Gasse (ub) amedee-ubuntu at
Thu Jun 24 07:39:50 UTC 2010

On Thu, June 24, 2010 04:33, Ashley Benton wrote:
> On Wed, Jun 23, 2010 at 6:42 PM, NoOp <glgxg at> wrote:
>> On 06/23/2010 04:30 PM, Ashley Benton wrote:
>> > Hi,
>> >
>> > I plugged an external hard drive into Ubuntu 9:10 and it didn't se it.
>> The
>> > hard drive seemed to  be working but Ubuntu didn't see it.
>> > The owner told me that it was fat32 and working with Windows. My
>> question
>> is
>> > why Ubuntu didn't see the hard drive and could the hard drive do
>> something
>> > (download files on the computer, install something or download files
>> from
>> > the computer...)
>> > I checked the kernel log, sys log, debug log, daemon log and user log
>> and
>> > didn't see anything concerning the hard drive.
>> ...
>> Why would you expect this to be a security concern?
> That is certainly nothing but it made me wonder what I missed. Security
> concern because I am wondering if the drive was actually working without
> my
> knowledge or why it didn't work.
>> Have you checked in gparted, lshw or similar to see if the drive is
>> available? Did you mention how the external drive is connected (usb,
>> etc)? Come on Meg, you've been around Ubuntu/linux long enough to check
>> the obvious first.
> Sorry I didn't try gparted or lshw or similar. The drive was plugged by
> usb
> for about 2 minutes, I tried to watch in media and my computer when it
> didn't appear by itself. I checked the logs after but there is no entry
> about it. I didn't know the person and couldn't take too much time looking
> at why so to simplify we used a usb key which worked without trouble.
> I'll try gparted and lshw next time it happens. Thanks for the answer

I advise the following debugging procedure for removable hardware:

1. unplug
2. open a terminal
3. type the following without quotes and press enter: "dmesg | tail -f"
4. plug the external drive while keeping an eye on dmesg
5. copy & paste the relevant output of dmesg and send it in an email to
this list. Use a pastebin if it's too much, but the dmesg output of a
removable device will hardly be more than a few lines.

dmesg = the kernel ring buffer. If the kernel doesn't see your removable
device, then basically you're screwed. If it does, but it doesn't mount
automagically, then myself and others on this list will be able to help


More information about the ubuntu-users mailing list