[Ubuntu Sound?] was Re: Please, Ubuntu, do not embarrass me again!

Basil Chupin blchupin at iinet.net.au
Thu Jun 10 09:20:53 UTC 2010


On 10/06/10 13:52, NoOp wrote:
> On 06/05/2010 09:10 AM, Basil Chupin wrote:
>    
>> I am using Lucid with everything which I normally use working perfectly.
>> The main things are multi-media (TV, DVDs, CDs). So, I create the USB
>> Starup Disc thinking that it will contain my system settings which will
>> allow me to reboot into my system as painlessly as possible in case of
>> emergency.
>>
>> I have a friend whose system (and his wife's) has been hit by
>> trojans/virii and I have had to go out to get him out of trouble. I have
>> been trying to get him to move to Linux for some time. And he is also
>> "into" a bit of multi-media.
>>
>> So, armed with the USB Startup Disc I go to his place to show him Ubuntu
>> and what it can do. Before going I made sure that the USB disc booted
>> correctly into Ubuntu. But stupid me.....
>>
>> The USB booted up on his latest, you beaut computer with everything
>> multimedia support for Windows, and he asked me, "What is this 'Samples
>> folder"; I opened it up and he then asked me for a  demo of the sound
>> file to do with the Aesop's Fable. And this is where the wheels fell off
>> :-( . Not a damn of tiniest squeaks came out from the speakers; total
>> and utter silence.
>>
>> OK, I had/have this problem when I installed Ubuntu on my own system but
>> I know that there is a fix which I did and which should have been
>> included on the USB Startup disc surely....surely? yes? In fact
>> absolutely NO.
>>
>> When it comes to sound, Ubuntu is totally braindead.
>>
>> Why?
>>
>> Because of 2 things:
>>
>> (1) it uses pulseaudio; and
>>      
> A bit late in the game, but your labeling of pulseaudio is probably not
> the issue at all. In both 9.10 and 10.04 IME the primary cause of sound
> issues has been alsa. Examples:
>
> https://bugs.launchpad.net/ubuntu/+source/alsa-driver
>
> <https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bugs?field.searchtext=&orderby=-importance&search=Search&field.status%3Alist=NEW&field.status%3Alist=INCOMPLETE_WITH_RESPONSE&field.status%3Alist=INCOMPLETE_WITHOUT_RESPONSE&field.status%3Alist=INVALID&field.status%3Alist=WONTFIX&field.status%3Alist=EXPIRED&field.status%3Alist=CONFIRMED&field.status%3Alist=TRIAGED&field.status%3Alist=INPROGRESS&field.status%3Alist=FIXCOMMITTED&field.status%3Alist=FIXRELEASED&assignee_option=any&field.assignee=&field.bug_reporter=&field.bug_supervisor=&field.bug_commenter=&field.subscriber=&field.tag=&field.tags_combinator=ANY&field.status_upstream-empty-marker=1&field.has_cve.used=&field.omit_dupes.used=&field.omit_dupes=on&field.affects_me.used=&field.has_patch.used=&field.has_branches.used=&field.has_branches=on&field.has_no_branches.used=&field.has_no_branches=on>
>
>
> https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/587388
> [0x103c360b Conexant CX20583 (Pebble HSF) Internal mic not functional -
> my bug report] Note that purging pulseaudio makes no difference.
> <https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/477154?comments=all>
> [When headphones are plugged in, the speaker does not get muted
> automatically. - 103 comments]
>
> In all fairness:
> https://bugs.launchpad.net/ubuntu/+source/pulseaudio
> <https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bugs?field.searchtext=&orderby=-importance&search=Search&field.status%3Alist=NEW&field.status%3Alist=INCOMPLETE_WITH_RESPONSE&field.status%3Alist=INCOMPLETE_WITHOUT_RESPONSE&field.status%3Alist=INVALID&field.status%3Alist=WONTFIX&field.status%3Alist=EXPIRED&field.status%3Alist=CONFIRMED&field.status%3Alist=TRIAGED&field.status%3Alist=INPROGRESS&field.status%3Alist=FIXCOMMITTED&field.status%3Alist=FIXRELEASED&assignee_option=any&field.assignee=&field.bug_reporter=&field.bug_supervisor=&field.bug_commenter=&field.subscriber=&field.tag=&field.tags_combinator=ANY&field.status_upstream-empty-marker=1&field.has_cve.used=&field.omit_dupes.used=&field.omit_dupes=on&field.affects_me.used=&field.has_patch.used=&field.has_branches.used=&field.has_branches=on&field.has_no_branches.used=&field.has_no_branches=on>
>
> Sound issues on any system/OS are problematic as there are hundreds of
> chipsets/sound cards/speaker jacks, etc., etc. I get as frustrated as
> the next person (particularly with my sound bugs/issues), but keep in
> mind that when someone fires up a new laptop et al that has preinstalled
> Winxyz, the software has alread been preconfigured, certified, and
> tested for that particular OS.
>
> Item #2 isn't much worth commenting on as it appears that even using
> alsamixer (which is intalled by default in cli form) didn't solve your
> supposed problem.
>    


Firstly, thank you for your response. I have saved your post so that I 
can refer to it when necessary in the future.

Re the last para: I did not find that alsamixer was installed by default 
in cli form. Trying to run "alsamixer" after ALT-F2 produced a totally 
non-existent response from a new installation of 10.04.

However, I will have to, once again, install 10.04 to make sure that 
what I just wrote is correct because I am working from memory.

> So how about you try this... reinstall your friend's system, from
> scratch, using a off the shelf retail Win OS, and let us know how well
> the initial results are. Not a restore system CD that has his/her latest
> settings and drivers on it, but an "off the shelf retail Win OS (of your
> choice) CD.
>
> Even easier; save a Win OS from your Win system to a USB (same as you
> did with linux) and take it to the friends house. Plug it in&  let us
> know how that turns out for you.
>    

Once again I thank you, Noop, for your response, and I greatly 
appreciate your contribution in many areas where people are asking for 
help. I always read your posts because they contain quite useful 
information.

I have noticed that you have not attempted for some time to give advice 
to anything I have posted because of my earlier contradiction of your 
claim about the efficacy of pulseaudio and as a result it seemed to me 
that you were having a pout-attack against my personage. Rightly or 
wrongly, I think you are about to have another pout-attack as a result 
of this response of mine.....Sad, but probably true.... :-( .

If you read my posts, at no time did I write that I was in the process 
of replacing my friend's Windows installation. All I wrote was that I 
having been trying to convince him to do so for sometime, and took a 
copy of Ubuntu on an USB Startup Disc flash drive to show him what it 
can do - but the whole attempt to show him what Ubuntu can do went down 
the toilet bowl because the stupid pulseaudio couldn't get the sound to 
work.

If you reread what I wrote you will find this to be true.


> Rather than blasting Ubuntu because you couldn't figure out how to
> modify the system to play Uncle Asop,

Who is Uncle Asop? Do you mean "Asok" by any chance?

I can "modify the system", but if I was a newbie would I really need to 
"modify" anything?

I ran SuSE for quite some time. While it was running alsa it had no 
problems: a simple setting during the setup stage got your sound working 
- even had the ability to test your sound to make sure that the 
setting(s) were correct. Now that it is also using pulseaudio it joins 
the "sound don't work from the box" club.


>   you might want to consider the
> accomplishment had you tried the same with a USB with a Win OS on it.
>    

Ce`?


With all due respects, people like yourself seem to miss the whole point 
of what others state about a distro, like Ubuntu, when they encounter 
hassles. Being a zealot is one thing; being responsive to stated 
problems which when solved would enhance the distro is something else again.

BC



-- 
Attorney:   All your responses MUST be oral, OK? What school did you go to?
Witness:    Oral.





More information about the ubuntu-users mailing list