Networking on my karmic laptop doesn't work any more!!

NoOp glgxg at
Tue Jun 8 19:22:18 UTC 2010

On 06/08/2010 08:12 AM, drew einhorn wrote:
> It worked just fine last night.
> First thing I noticed is that web pages are no  longer accessible.
> Then I looked for the NetworkManager icon in the panel.
> It's not there.
> I have another partition that boots into a test copy of lucid.
> rebooted to that partition.  Networking works there, so nothing
> happened to the laptop hardware or the access point.
> Then I tried plugging in a network cable for a wired connection.
> That didn't work either.

The missing NM applet may be telling. The applet is provided by
network-manager-gnome and is placed in the Notification area applet.

You may try:

$ ifconfig

to see if you actually have an IP.

$ sudo apt-get /etc/init.d/networking restart

and then check ifconfig to ensure that you've actually got an IP address
& then ping or etc to see if you can ping.

If networking is actually working but the NM applet just isn't showing
up, then it might be worth reinstalling:

$ sudo apt-get install --reinstall network-manager network-manager-gnome

If you do not have those packages archived on your system & have no
working network, you can download them via another machine & 'sneaker
net' them to the laptop:
scroll down to the "Download network..." and click on the appropriate
architecture (amd64 or i386). Download the .deb & reinstall.

But I'd first look at ifconfig that is actually showing. If you have an
proper IP address, then you may actually have a working network connect
& just not know it. Try a ping to etc.

If not, post the results of ifconfig, iwconfig, & 'cat

More information about the ubuntu-users mailing list