Wireless Card BCM4312

J dreadpiratejeff at gmail.com
Wed Jun 2 14:21:44 UTC 2010

On Wed, Jun 2, 2010 at 09:31, Kaushal Shriyan <kaushalshriyan at gmail.com> wrote:
> Hi,
> I have the below wireless card. It does not work on Ubuntu Linux 10.04, I
> have tried both the drivers Broadcom STA Wireless Drivers and Broadcom BCM43
> located under System > Administration > Hardware Drivers. It did not worked.
> 0e:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g (rev 01)
> Please suggest/guide.

How do you know it did not work?

How did you enable/disable the STA driver?

What steps did you take to see if it worked or not?

I have a BCM4312 wireless card and it works well using the STA driver
that is suggested by jockey (the Hardware Drivers tool).

First, run hardware drivers and tell us WHICH one you have installed
and enabled.
Then, the output of: dpkg -l |grep broadcom
Then, the output of lsmod |grep wl
Then, right click on network manager icon and make sure Enable
Networking and Enable Wireless are checked
Then, left click on network manager icon and make sure you're actually
CONNECTED to an access point.  If not, connect to one of the ones it

I HAVE found that it can take 30 - 45 seconds sometimes to finish
scanning and show all available access points...

Finally, post the output of: ifconfig -a

NOTE: you may need to use sudo before some of those commands (like ifconfig)

More information about the ubuntu-users mailing list