System Lockup Problem continues *HELP*

NoOp glgxg at
Tue Jul 20 02:18:33 UTC 2010

On 07/19/2010 05:51 PM, Jay Ridgley wrote:
> Folks,
> I have found that my Dell C610 laptop works fine with a wired connection, 
> however, it locksup (sooner or later) with a wireless connection.
> I have been trying to figure out what is going on. First I thought it was a 
> wireless mouse problem but the wired connection uses the same mouse.
> I also thought that when I discovered that swap was not being mounted that could 
> be the problem, not the case.
> With a wireless connection running the latest lockup happened (which is the 
> first time I was able to get any kind of error indication) this morning.
> I have been reviewing the logs and have discovered that in /var/log/syslog about 
> 0336 this morning there was a  message:
>   Jul 19 03:36:12 nomad kernel: [ 8489.956069 ] BUG: scheduling while atomic:
>   irq/11-b43/1009/0x00000101
> That was followed by a number of Call Trace entries (lots of lines)
> The system was locked up when I checked about 0510.
> Research shows a reported bug # 586967 covers the situation. Doing some 
> additional searching outlines a potential fix by unloading module 3c59x under 
> the same bug.
> How do I unload module 3c59x?  I have tried placing it in the blacklist in 
> /etc/modprobe.d/blacklist.conf and rebooting. After that lsmod showed 3c59x 
> still being loaded.

For added reference to help with Jay's problem (we've tried off list):
another related:

More information about the ubuntu-users mailing list