[Resolved] Re: No login screen after splash

NoOp glgxg at sbcglobal.net
Mon Jul 19 22:19:33 UTC 2010


On 07/19/2010 06:49 AM, Jeff Hsu wrote:
...
>> Hmmm the first errors I get are from the apt-get install -f step:
>>
>> Unpacking replacement gnome-applets
>> dpkg: warning: old post-removal script returned error exit status 245
>> dpkg - trying script from the new package instead ...
>> dpkg: error processing
>> /var/cache/apt/archives/gnome-applets_2.30.0-0ubuntu2_amd64.deb
>> (--unpack):
>>  subprocess new post-removal script returned error exit status 245
>> dpkg: error while cleaning up:
>>  subprocess new post-removal script returned error exit status 245
>>
>> This error occurs pretty much at each step down until at the last dpkg
>> --configure -a step:
>>
>> Errors were encountered while processing:
>>  gnome-netstatus-applet
>>  deskbar-applet
>>  gnome-applets-data
>>  gnome-panel-data
>>  gnome-panel
>>
>> I also try to repair broken packages in recovery mode and I get the
>> same "post-removal script returned error exit status 245"
>>
>> checking .xsession-errors the first error is after a new xsession:
>> (polkit-gnome-authentication-agent-1:1564): GLib-GObject-WARNING **:
>> cannot register
>>  existing type `_PolkitError'
>>
>> There seems to be a bug in launchpad about this, though no fix is
>> known.  Another thing I do in common between installations is use
>> google chrome.
>>
> 
> Okay I fixed the problem.  I had installed zlib 1.2.5 from source
> from: http://www.zlib.net/.  Once I sudo make uninstall from the zlib
> source directory it fixed EVERYTHING from the dpkg errors to the
> applet errors to the login.  I'm not sure why that could of caused so
> many problems.
> 

Cool! Glad you got it sorted out.






More information about the ubuntu-users mailing list