no AppleTalk?

Pete Gontier pete at
Mon Jul 12 17:34:14 UTC 2010

I've spent too many years crawling through old code to be blaming anyone for
anything. :-)

You seem to be suggesting is that 'route' and "netstat' are closely related,
'netstat' has been broken for a long time, and thus 'route' isn't a good
indicator of anything. Fair enough.

Further, you seem to suggest that AppleTalk is indeed in the Ubuntu kernel,
and there must be some other reason all the netatalk userland programs I've
tried say:

atp_open: Cannot assign requested address

(Even though I've made no explicit attempt to assign any address.) What else
can I try to diagnose this? (I've already tried making the interface
netatalk is supposed to use explicit.)

Pete Gontier <>

On Mon, Jul 12, 2010 at 10:11 AM, Hakan Koseoglu <hakan at> wrote:

> Pete,
> On 12/07/10 17:41, Pete Gontier wrote:
> > I've installed netatalk, but it only runs via IP unless it finds some
> > optional kernel support (DDP).
> >
> > 'route -A ddp' says:
> >
> > Error opening /proc/net/atalk_route: No such file or directory
> > DDP (AppleTalk) not configured on this system.
> >
> > That would appear to be my answer: Ubuntu's kernel lacks the optional
> > DDP support.
> Don't be quick to blame Ubuntu for that message. Upstream bug is still
> open after 11 years:
> Ubuntu kernel has the appletalk module, it loads up correctly. I don't
> have any Apple device to test it any further.
> --
> ubuntu-users mailing list
> ubuntu-users at
> Modify settings or unsubscribe at:
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the ubuntu-users mailing list