building and installing a new kernel makes my system unbootable

Robert P. J. Day rpjday at crashcourse.ca
Tue Jul 6 10:58:34 UTC 2010


On Tue, 6 Jul 2010, Markus Schönhaber wrote:

> 05.07.2010 20:01, Robert P. J. Day:
>
> > $ sudo make modules_install
> > $ sudo make install
> > $ sudo update-initramfs -c -k 2.6.35-crash+
> > $ sudo update-grub
> >
> >   that's worked fine until now, but with this kernel tree, if i do the
> > above and reboot, i not only can't stop in GRUB, but the boot fails as
> > the kernel panics, claiming it can't mount a root file system.
> >
> >   i recovered by booting off the CD into rescue mode, mounting
> > /dev/sda1 (/boot), then literally editing grub/grub.cfg and deleting
> > the entries for that new kernel.  nothing else would allow me to boot.
>
> If GRUB doesn't work with the entries for your self-built kernel but
> does without them, it seems that exactly these entries makes GRUB choke.
> WAG: Does it get better if you rename your kernel and initrd files to
> something that doesn't end with a '+' character?

  i'm testing that right now, but an earlier example worked just fine
and, in fact, the stock kernel build process explicitly appends a "+"
in certain cases.

  anyway, i just built a 2.6.35-rc4 kernel, about to install, create
initramfs, update grub and reboot.  stay tuned ...

rday


-- 

========================================================================
Robert P. J. Day                               Waterloo, Ontario, CANADA

        Top-notch, inexpensive online Linux/OSS/kernel courses
                        http://crashcourse.ca

Twitter:                                       http://twitter.com/rpjday
LinkedIn:                               http://ca.linkedin.com/in/rpjday
========================================================================


More information about the ubuntu-users mailing list