building and installing a new kernel makes my system unbootable

Robert P. J. Day rpjday at
Mon Jul 5 18:01:11 UTC 2010

On Mon, 5 Jul 2010, Chan Chung Hang Christopher wrote:

> Robert P. J. Day wrote:
> >   some strange things happening here -- for the first time, after i
> > configured and built a new kernel, i ran "make deb-pkg" to turn it
> > into a .deb package file, then used "dpkg" to install that, after
> > which i still apparently had to run the appropriate incantations of
> > "update-initramfs" and "update-grub", then i rebooted.
> >
> >   the boot process is clearly trying to boot the new kernel
> > (2.6.35-rc4+), only to fail with an error trying to mount the root
> > filesystem.  no problem, thinks i, i'll just reboot, drop into GRUB
> > and select the earlier, working kernel ... except that nothing i do
> > will get me to GRUB -- not SHIFT, ESC or TAB.  when i installed my ner
> > kernels manually, SHIFT always worked, but now, i have no idea what's
> > changed.
> sounds like stage1 not being able to load stage2
> >
> >   i suspect i'll boot off of the CD and poke around, but i'm open to
> > suggestions -- why would this have happened?  and is there
> > *something* that will get me to GRUB?
> reinstall grub.

  just to describe what i'm doing, i have the current git pull of the
kernel source tree (apparently, 2.6.35-rc4), and i've followed exactly
the same instructions i documented here:

that i've used just fine for a while -- do a build and:

$ sudo make modules_install
$ sudo make install
$ sudo update-initramfs -c -k 2.6.35-crash+
$ sudo update-grub

  that's worked fine until now, but with this kernel tree, if i do the
above and reboot, i not only can't stop in GRUB, but the boot fails as
the kernel panics, claiming it can't mount a root file system.

  i recovered by booting off the CD into rescue mode, mounting
/dev/sda1 (/boot), then literally editing grub/grub.cfg and deleting
the entries for that new kernel.  nothing else would allow me to boot.

  i have no idea why this is happening -- this recipe has worked fine
until now.



Robert P. J. Day                               Waterloo, Ontario, CANADA

        Top-notch, inexpensive online Linux/OSS/kernel courses


More information about the ubuntu-users mailing list