Rescue md/software RAID array

Matthias Brennwald matthias at
Mon Jul 5 17:30:38 UTC 2010

Dear all

Last weekend my server "crashed". The machine was running Ubuntu Server 10.04. The file system (except /boot, which is on a different disk) was on a md software RAID (3 disks in RAID 5, plus 1 spare disk). This morning I tried to log in remotely using ssh, but immediately after login the terminal was closed again (so the machine was still running somehow, but it did not want me to be logged in).

I didn't think much and tried to reboot the machine (I forgot to try logging in directly at the machine). During booting I got a message that the md RAID was degraded, and if I want to continue booting. I answered yes. Immediately after this, I got a message saying that a device/disk UUID could not be found and then got an "(initramfs)" shell.

I am able to boot using a rescue CD (I used the Ubuntu alternate installer disk, because the Live CD does not have md/softraid support), but I don't really know how to proceed in order to fix things. I would greatly appreciate any hints on how to get the machine up and running again. For instance, which commands should I try after booting into the Ubuntu rescue CD?


More information about the ubuntu-users mailing list