Latest Firefox 3.6.6 - I don't like it...

Robert Holtzman holtzm at cox.net
Fri Jul 2 00:58:48 UTC 2010


On Thu, Jul 01, 2010 at 05:44:59PM +1000, Basil Chupin wrote:
> On 01/07/10 08:05, Robert Holtzman wrote:
> > On Wed, Jun 30, 2010 at 04:20:01PM +1000, Basil Chupin wrote:
> >    
> >> I had a perfectly working combination of Thunderbird and Firefox whereby
> >> clicking on an URL link in TB would bring up that link in
> >> Firefox......until this latest version, 3.6.6, installed earlier today
> >> :-) . That nice link has now been destroyed.
> >>
> >> FF is my default browser, its path is written correctly in its
> >> preferences (and it starts OK using this path on a command line), the
> >> config file for TB hasn't been altered....
> >>
> >> Anyone else suffering this annoyance following the upgrade of FF?
> >>      
> > Yup.
> 
> Oh good, I wasn't imagining it then :-) .
> 
> >   Upgraded from FF 3.0.x to 3.6.6 (some jump, huh?) and suddenly
> > couldn't bring up FF from a URL in Mutt. Ran a few searches and found the
> > fix was to add "export BROWSER=/usr/bin/firefox" to my ~/.bashrc file.
> > After I verified that it worked I commented it out, rebooted, and saw
> > the same problem. Uncommented the entry and everything was fine.
> >    
> 
> Unless what you wrote above is not quite right or I am not reading it 
> correctly, adding a line into my .bashrc exactly as you show produces 
> the same result as one from a dead horse :-( .

I'll be damned. It looks like Alpine, which I also have on my system,
doesn't have the problem but Mutt does. Alpine has the FF path right in
it's configuration file but Mutt depends on urlscan or urlview (separate
programs from Mutt) to call the browser. The
/usr/share/doc/urlscan/README file says 

"urlscan uses sensible-browser to invoke the default  Web browser of
the  current environment.   To choose  a particular  browser,  set the
environment variable BROWSER; e.g.,

export BROWSER=/usr/bin/epiphany"

which, of course, changes to FF. Only used T'bird briefly a few years
ago and can't remember the where browser is called but he ~/.bashrc 
entry *should* be a universal fix (it says here in fine print).  


-- 
Bob Holtzman
Key ID: 8D549279
"If you think you're getting free lunch,
 check the price of the beer"
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
URL: <https://lists.ubuntu.com/archives/ubuntu-users/attachments/20100701/c8876f24/attachment.pgp>


More information about the ubuntu-users mailing list