Samba Password Authentication is failing

Peter Salzman p at
Sun Jan 31 16:47:33 UTC 2010

On Sun, Jan 31, 2010 at 7:32 AM, Tom H <tomh0665 at> wrote:
>> This problem has been kicking my butt for a couple of days now. The
>> computer names are:
>> Linux: satan (Kubuntu)
>> Windows: lucifer (WinXP)
>> I want to mount Linux shares into "My Network Places" on Windows. My
>> username on both machines is "p". The security related directives
>> of the global section of smb.conf is:
>> ### security
>> ###
>> security = user
>> encrypt passwords = true
>> # passdb backend = smbpasswd:/etc/samba/smbpasswd
>> passdb backend = tdbsam:/var/lib/samba/passdb.tdb
>> browseable = true
>> If I set the security model to "share" with zero security everything
>> works fine: I can access the Linux shares from the Windows machine.
>> However, I'm trying to set this up correctly.
>> Double clicking a share icon on the Windows machine (i.e. when I try
>> to access a Linux share), I get a Win error pop-up:
>> "\\Satan\tmp is not accessible. You might not have permission to use
>> this network resource. Logon failure: unknown user name or bad
>> password"
>> On the Linux side, the log message says:
>> netbios connect: name1=SATAN name2=LUCIFER
>> netbios connect: local=satan remote=lucifer, name type = 0
>> setup_new_vc_session: New VC == 0, if NT4.x compatible we would close
>> all old resources.
>> Authentication for user [p] -> [p] FAILED with error NT_STATUS_WRONG_PASSWORD
>> Authentication for user [p] -> [p] FAILED with error NT_STATUS_WRONG_PASSWORD
>> However, the passwords *should* be the same. First, I verified that
>> my Linux Samba account exists using "pdbedit -Lv", and it looks good:
>> Unix username: p
>> NT username:
>> Account Flags: [U ]
>> Home Directory: \\satan\p
>> Profile Path: \\satan\p\profile
>> Domain: SATAN
>> # smbpasswd -D10 -c /etc/samba/smb.conf p
>> # ll /var/lib/samba/passdb.tdb
>> -rw------- 1 root root 36K 2010-01-30 15:06 /var/lib/samba/passdb.tdb
>> Everything looks correct and healthy.
> Are you trying to access "c:\tmp" on satan?
> What are your master browser settings in smb.conf? Have you tried to
> set the username in the Windows authentication box as
> "ipaddressofsatan\p"?

No, I'm sitting at a Windows machine trying to mount /tmp from Linux.

The browser settings (wasn't 100% sure of this, but I think this is correct):
   # Win Networking stuff
   domain master    = yes
   local master     = yes
   preferred master = yes

That was a good suggestion.  I tried setting the username as
"ipOfSatan\p" but it still didn't work.

Any other ideas?


More information about the ubuntu-users mailing list