Java not working in Firefox 3.6

Jim Byrnes jf_byrnes at comcast.net
Thu Jan 28 20:59:45 UTC 2010


Carlos Alberto Alves wrote:
> On 01/28/2010 06:39 PM, Jim Byrnes wrote:
>> Carlos Alberto Alves wrote:
>>> On 01/28/2010 12:48 AM, Jim Byrnes wrote:
>>>> Jean Levasseur wrote:
>>>>> Hello Jim. you might be interested into installing apt://etckeeper
>>>>>
>>>>> etckeeper is a program that will put your whole /etc (system wide
>>>>> configuration stuff)at under revision control, so after any change you
>>>>> make in a file under this folder, you emit the command (without the
>>>>> double-quotes) "sudo etckeeper commit 'description of the change
>>>>> here'".  Then after, it is easy to just track the changes in
>>>>> configurations, and to revert to a previous state if something you did
>>>>> broke the system.  As of your own personnal folder, I'm personnally
>>>>> using Déjà -Dup, which is an incremental backup utility with the
>>>>> ability to get some files (configurations in this case) into a
>>>>> previous state.  Those 2 little apps help me keep my system clean and
>>>>> serve me as backup as well!
>>>>>
>>>>> Good luck!
>>>>>
>>>>> -Foxmike.
>>>>>
>>>> Thanks for the tip, I'll check it out.
>>>>
>>>> Regards,  Jim
>>>>
>>> I had the same problem with Firefox 3.6.1. I solved it trhu a tip I
>>> found on the net. The main problem is the java plugin file that has
>>> changed. It used to be...
>>>    /usr/lib/jvm/java-6-sun/jre/plugin/i386/ns7/libjavaplugin_oji.so
>>> and now it is...
>>>    /usr/lib/jvm/java-6-sun-1.6.0.14/jre/lib/i386/libnpjp2.so
>>> Go to  /usr/lib/firefox-3.6.1pre/plugins and then re-link...
>>>    sudo ln -s /usr/lib/jvm/java-6-sun-1.6.0.14/jre/lib/i386/libnpjp2.so
>>> Problem solved!!!
>>> ;-)
>> I received that same advice a couple of days ago and unfortunately it
>> did not work for me.  I see you are /i386 while mine is /amd64.  I made
>> so many changes trying to get it to work I probably put the system in
>> such a state that it had no chance to work, so I reformatted and
>> reinstalled Ubuntu.  I am just about ready to tackle java and firefox
>> again, this time in a more orderly manner, I hope.
>>
>> Thanks,  Jim
>>
> 
> You should check to see if the plug-in files (libjavaplugin_oji.so and 
> libnpjp2.so) have the same name on a different location.
> You might solve your problem this way. :|

Just checked and there is no libjavaplugin_oji.so on this machine now.

Regards,  Jim




More information about the ubuntu-users mailing list