Missing shared object? solved

nepal nepal.roade at googlemail.com
Sat Jan 16 11:08:58 UTC 2010

On Monday 11 Jan 2010 22:10:22 nepal wrote:
> Hello List.
> Can anyone confirm that I have a problem here. This is a 64 bit
>  Karmik install.
> I am trying to compile some source and when I run ./configure it
> eventually stops with an error for cannot find "libm".
> I have checked the /usr subdirectories /lib, /ib32 and /lib64 for
> libm.so and libm.a
> There is a file libm.a (apparently libm is a math library, the .a
>  is the static library file and the .so is the dynamic library
>  file.)
> On searching for libm.so though, all the entries are actually just
> pointers to a libmxxxxx.so.6 which does not exist. So this actual
> library file is missing. I have not been able to find anything that
>  I could install that would correct this.
> Can anyone help please?
> TIA.
> nepal.

Thanks for all your replies. I finally sorted this out by discovering 
that the x development libraries were not installed and upon 
correcting this the compile completed successfuly. Thanks for the help 
and pointers.


More information about the ubuntu-users mailing list