Beginner Q1: Linux incapable of handling FDD?

Avi Greenbury avismailinglistaccount at
Thu Jan 14 17:24:04 UTC 2010

Thomas Blasejewicz wrote:

> Question 1: for confirmation.
> Recently I have (tried to) used OpenSUSE (10.3 / 11.1 / 11.2) for a
> while and am now trying to use Ubuntu (9.10)
> The computer I use exclusively for experimenting with Linux does has a
> functional FDD. I tried to use it under OpenSUSE, asked the relevant
> question on a SUSE mailing list, then tried to use it under Ubuntu
> (Japanese version).
> Apparently Linux CANNOT handle floppys and someone pointed out, that
> this is a "bug":

This bug isn't in Linux (which is just the kernel) per-se, but a
component used in a distribution of it. Fortunately, most of these
components can be circumvented if need be. That one is concerned with
automatic detection and configuration of removable devices. 

Here, it doesn't appear to properly support the floppy drive. As a
not-entirely-rigorous test of OS support try the following command in a
terminal (Applications->Accessories->Terminal):

sudo mkdir /mnt/floppy
sudo mount /dev/fd0 /mnt/floppy

If the second command succeeds (it will produce no output on success)
you do have floppy support. If it fails, please reply with the error

For what it's worth, XFCE in Debian Lenny just mounted a floppy disk
here (through XFCE's dialog for it). 

Avi Greenbury ;)

More information about the ubuntu-users mailing list