Non-booting machine and missing user rights on USB drives

Ari Torhamo ari.torhamo at
Mon Jan 11 10:46:07 UTC 2010


Someone just sent a message to me that Ubuntu (9.10) machine that I
maintain has stopped working. The boot process stops somewhere in the
middle, and this message is shown:
"One or more of the mounts listed in etc/fslab (tai fstab) cannot yet be
mounted: /home:waiting for UUID=dd2d0d0 [...] Press ESC to enter a
recovery shell."
And after pressing ESC, this:
""General error mounting filesystems. A maintenance shell will now be
Control-D will terminate this shell and re-try." root@****-deskstop:~#" 
The problem came up on the last friday, when the machine was booted for
the first time after the previous tuesday. The user thinks that some
updates were offered and installed on tuesday, but the machine wasn't
rebooted then. Does anyone know, if there are others who have had
problems with the last weeks updates and if there's a simple solution
for the situation? I googled for the error message, but didn't get any
helpful results. If it gets complicated, I'll go there myself and just
reinstall Ubuntu - after doing a hard drive health check (on the other
hand Windows works normally, so there likely is nothing wrong with the
hard drive).

I advised the user to use the live CD for necessary work until we get
the problem fixed. He then reported that he is not allowed to access
he's files on his USB drive, because he doesn't have the rights to do
so! :-o The same thing happened recently to the user of another machine
that I maintain: he attached an external USB drive to his system, and
everything worked nice and fine otherwise, but he wasn't allowed to
write into the drive because he didn't have the rights. This is
something I have to say I don't understand: why do users have to face
this kind of usability in 2010, when Linux and Ubuntu have been in the
existence for so long. I remember the user rights issue of Ubuntu being
discussed a few years ago, and according to my memory the outcome was
that the problem was being worked on and it was going to go away soon.
Why then, in 2010, users still aren't given rights to their own devices
that they plug in into their own computers?

>From the tone of the voice I can tell, that the person with non-booting
machine isn't too happy with Ubuntu any more :-/ He used to be
understanding with problems, but they just keep coming. I used to oppose
the idea that one Ubuntu release should be used just for fixing bugs,
but now I'm beginning to think that perhaps it's a good idea. I applaud
the great progress that has been made in so many areas, but
unfortunately the amount of bugs that many users face lay a shadow above
these achievements.


More information about the ubuntu-users mailing list