File transfer problem

Johnneylee Rollins johnneylee.rollins at gmail.com
Sun Jan 10 22:24:36 UTC 2010


On Sun, Jan 10, 2010 at 2:11 PM, Karl F. Larsen <klarsen1 at gmail.com> wrote:
>
>        Consider this: you have a hard drive in a small case with a
> lot of files on an ext3 file system that is accessed via a USB
> port. You plug the USB into a Ubuntu 9.04 computer and a panel
> comes up showing all the files. You plug the USB into WinXP it
> shows up in My Computer but shows no files.
>
>        So you take the files to the Ubuntu but there is no way to
> put them in the /dev/sda5 partition. I tried sudo cp -a *
> /dev/sda5 and it errors out.
>
>        Then I tried to mount the /dev/sda5 at /mnt but that fails
> too. The call I tried was $ sudo mount -t vfat /dev/sda5 /mnt
> and changed vfat to ntsf and several others and just got an
> error message.
>
>        What I would like to do is copy the files on the little hard
> drive to the computer which has WinXP and Ubuntu 9.04 in the
> /dev/sda5 partition.
>
>
>        Does anyone have an idea how to start?
>

Mount the ext3 partition -> properly mount the other partition -> cp
-Rv /path/to/ext3partiton/* /path/to/other/

First step is rather simple, as you've been doing it this whole time,
I'll skip explaining it.
The second step needs a bit more attention, when you formatted the
partition on whatever device you used, what filesystem type did you
choose? After you have that information, mount the drive in the
command line like this:
sudo mkdir /media/mount
sudo mount -t FILESYSTEMTYPE /dev/sda5 /media/mount
The filesystem type is ntfs if you formatted it as such, and if you
formatted it as fat32 it will be vfat.
Last step is simple.
sudo cp -Rv /path/to/mounted/device/ /media/mount/

~SpaceGhost




More information about the ubuntu-users mailing list