Problem With Scanner

Graham Todd grahamtodd2 at googlemail.com
Fri Jan 8 12:42:56 UTC 2010


I have a Packard Bell Diamond 1200 Plus scanner, and I'm having
problems with it scanning through XSane, Quiteinsane, and the Gnome
scanner utility.  I should be most grateful if anyone can suggest
anything I haven't tried.

Calling sane-find-scanner, the output shows:

found USB scanner (vendor=0x055f, product=0x021c [USB Scanner],
chip=GT-6816) at libusb:003:002

which shows that its been found  The backend is the SANE GT68xx
Backend, and from backend homepage I see that my scanner is a clone of
the Mustek BearPaw 1200 CU: this is where it gets confusing.

The listing for my Packard Bell scanner shows two firmware files for
it, PS1Dfw.usb and PS1Gfw.usb.  However these firmware files are shown
as relating to the Mustek BearPaw 1200 CU Plus, and the Mustek BearPaw
1200 CU has another firmware file, ps1fw.usb.

Placing these three files together or seperately
in /usr/share/sane/gt68xx/ lets Quiteinsane or XSane recognise my
scanner (albeit as the Mustek Bearpaw model) but as soon as I try and
*use* the scanner front ends, an error message comes up to the effect
that the device failed to open, 'gt68xx:libusb:003:002': Invalid
argument.

I've tried rebooting but the same happens.  Could anyone help before I
pull what's left of my hair out?

-- 
Graham Todd







More information about the ubuntu-users mailing list