Program Menus not Updating When Installing new Programs

Andrew Farris flyindragon1 at
Thu Jan 7 23:41:41 UTC 2010

On Wed, 2010-01-06 at 23:17 -0600, Andrew Farris wrote:
> Hey everybody,
> I've been having an odd intermittent issue with menus not updating when
> installing new programs on Ubuntu 9.10, x64 bit. For most programs I've
> tried to install so far (all from official repositories) I get no menu
> entries after the install, despite the fact that menu entries exist in
> the packages themselves. I've never had this issue before, and I'm not
> sure what to do to fix it. See below for important info...
> Essential info:
>         Release: Ubuntu 9.10, x64 bit
>         Kernel: Linux 2.6.31-17-generic
>         GNOME: 2.28.1
>         Installing programs from official repositories
> Programs trying to install/results (no particular order):
>         BlueProximity  -  Has Menu Entry
>         galternatives  -  No menu entry (menu file present in package)
>         TORCS  -  No menu entry (menu file present in package)
>         Prism  -  No menu entry (menu file present in package)
>         Java(usually has a management interface)  -  No menu entry (menu
>         file present in package)
>         The Mana World Client  -  Has menu entry
>         ghextris  -  Has menu entry
>         Gnome Hex Editor  -  Has Menu Entry
>         ERIC Python IDE  -  Has Menu Entry
>         Synfig Studio  -  No menu entry (menu file present in package)
>         supertux  -  No menu entry (menu file present in package)
>         supertux2  -  No menu entry (menu file present in package)
>         Singularity  -  Has Menu Entry
> What I've tried:
>         Installing from USC and difference
>         update-menus...No changes. I have 'menu' installed
>         update-desktop-database...Give me the following error:
>                 "
>                         No directories in update-desktop-database search
>                         path could be processed and updated.
>                 "
>                 I've tried adding the paths /usr/share/menu
>                 and /usr/share/applications to the call, and nothing
>                 different happens. There also appears 
I hate to just add a line or two to this, but due to all huge-threaded
discussions recently, I fear my message may have gotten lost in the

I wanted to add, I tried a few more applications, and here's the
        Burgerspace - Got a menu entry
        Agave - got a menu entry
        Kobo Deluxe - got a menu entry
I started trying different things, and i thought to check my
~/.local/share/applications folder, and i found that there were numerous
old menu entries present of programs I haven't had in years... over 500
individual .desktop files in there. After deleting some of them, I tried
installing some of the programs again, and it appears that they now gain
a menu entry as expected... so perhaps that was the issue.

I suppose I'll consider this solved for now, unless  I start running
into more programs that won't get menu entries.

Registered Linux User: 473690
Registered Ubuntu User: 22747

More information about the ubuntu-users mailing list