Connecting a Wireless Router to a Wired Network

Jay Ridgley jridgley2 at
Thu Feb 11 04:05:32 UTC 2010

 > On 2010-02-10, Bill Marcum <marcumbill at> wrote:
>> > On 2010-02-10, Jay Ridgley <jridgley2 at> wrote:
>> > Folks,
>> >
>> >   What files do I need to tweak to add a wireless router to my 
>> > network? I have 3 NICs on my firewall eth0 - Internet, eth1 - LAN and 
>> > eth2 that I want to use as an access point via an AirLink101 AR430W 
>> > router. I have the information needed to configure the router AFTER I 
>> > get it connected. I have added it to /etc/network/interfaces and 
>> > ifconfig shows it correctly. What other areas do I need to look into?
>> >
>> > What I am getting is one of two responses either Firefox can't find it or a 
>> > message from Apache2 about an Index... no login screen.
>> >
> The message from Apache2 would mean either something is seriously wrong
> with the router, or you're talking to one of the computers on your LAN.
> Are you sure you have the correct IP address for the wireless router? Is
> it in a different subnet than your other LAN? What is the output of
> "route -n"?


I have just tried to bring up a brand-new out of the box AirLink101 AR430W and 
still get the Index of / message from Apache. The output of route -n follows:

cdjsys at mateo:~$ route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface U     0      0        0 eth2 U     0      0        0 eth1   U     0      0        0 eth0     U     1000   0        0 eth1         UG    0      0        0 eth0         UG    100    0        0 eth1



eth2      Link encap:Ethernet  HWaddr 00:c0:4f:45:cf:06
           inet addr:  Bcast:  Mask:
           inet6 addr: fe80::2c0:4fff:fe45:cf06/64 Scope:Link
           RX packets:31 errors:0 dropped:0 overruns:0 frame:0
           TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
           collisions:0 txqueuelen:1000
           RX bytes:11650 (11.3 KB)  TX bytes:0 (0.0 B)
           Interrupt:11 Base address:0xc000


Please let me know what I need to do next. Currently I have disconected the 
power to the unit and set eth2 down.


Jay Ridgley
jridgley2 at
Registered Linux User ID - 9115
Registered Ubuntu User ID - 23320

More information about the ubuntu-users mailing list