Dbus, ETC Issues On Jaunty

Leonard Chatagnier lenc5570 at sbcglobal.net
Wed Feb 10 20:46:20 UTC 2010

Cant log into kde on Jaunty. First time I've seen this issue on Ubuntu running kde. Also tried to login to gnome which also failed.
Here's whats happening:
Messages: After kde login.
Failed to open connection to "system" message bus: Failed to connect to socket /var/run/dbus/system_bus_socket:No such file or directory
?????-rc,d: initscriptss dbus, action forced -reload failed(sorry couldn't read my own writing. ATF, looks like make but prob not)

After the above, I booted into recover mode and reinstalled NM and others including dbus. Also ran "fix broken packages" and aptitude -f install and dpkg --configure -a from a root prompt with internet. Earlier, I had added a virtual screen resolution and mode lines to xorg.conf while in kde in order to get my screen res above 800x600 and rebooted several times without issue.
The issue continued so I loged in in safe mode and ran the following based on googling the original error message: I restarted Hal and dbus(/etc/init.d * restart). the first time I did this I got a message to the effect that landscape client did not start or something to that effect and it asked me if I wanted to start it or something and I y'd it. The following output was very confusing, didn't write it down, but it did refer to a couple or urls that had canonical and landscape client in them.
I finished it out, guessing the answers, and it errored out saying it wasn't correct. I was in the middle of doing the restart landscape client thing so didn't visit the links given in the process of restarting Hal and dbus. Should have I guess. Tried running the restart Hal and dbus again but the message about landscape client never came up again. 
After some more reboots this comes up:
On logging in to kde:

No write accoss to $/ICEauthority  Hit Ok. Then
could not start ksmserver.
Check your installation   (Well, been doing that on this machine for several days now on three different ubuntus)

I ls -al ICEauthority and got:
-rw  root:root  (which is what it is on every ubuntu install I've seen)
Well, I'm wrong about that as I just checked on this version and found it is user:user.  I'll change it on Jaunty and see if it fixes the issue. Who knows how it got changed???
Well that did fix my Jaunty but not from recovery mode(perhaps a typo as I found ICE recover on fail safe mode). After chown again in fail safe mode and making sure the dot preceded the name, I was able to log in.
Sorry for the noise but maybe this will help someone experiencing the same issue. 
Leonard Chatagnier
lenc5570 at sbcglobal.net

More information about the ubuntu-users mailing list