remove kubuntu

Jonesy gmane at
Mon Feb 8 22:52:05 UTC 2010

On Sat, 6 Feb 2010 18:54:34 +0000, Avi Greenbury wrote:
> John Heinen wrote:
>> I have ubuntu  and kubuntu along with win xp on the drive, I need to
>> remove kubuntu, I read somewhere that is was easy, how do I do it.
>> Thanks
> It depends what method you followed to have both. 
> If you installed the kubuntu desktop environment into a Ubuntu install,
> you will tell the system which one you want to use at the login screen,
> probably by using a menu called 'session' or similar. You will have got
> there through installing a package called 'kubuntu-desktop', and the
> best way to remove it is to run the command in NoOp's link:


I performed the above procedure (and more) this last weekend.
I'm happy to report: it went smoothly.

Background: Back in December I bought a Zareason Terra A20 Netbook.
Offered were several linux loads -- as well as no operating system.
Being a long-time KDE user, I chose kubuntu (9.10) -- not realizing
I was going to be saddled with KDE 4.  I did not (do not) like
KDE 4, so I installed KDE 3.5 as an additional window manager.
All-in-all it worked ok for me -- for selected definitions of "ok".
I could see some 'quirkiness', some snafus, and some inconsistancies
with KDE 3.5 running on a designed-for-KDE 4 system.

I decided to reduce kubuntu to ubuntu, thence convert it into

So -- making sure I had a bootable Ubuntu 9.10 USB thumb drive,
just in case I had to start from scratch -- I performed the
monstrous `apt-get remove .... && apt-get install ubuntu-desktop` 
process laidout at:

Immediately after that -- in the _same_ terminal window, I installed
KDE 3.5 via the process laid out at:

(Don't let the 'Jaunty' reference put you off.  There are karmic
instructions there, as well.)

Re-booted  --  and Bob is now my uncle.

I figured there would be some detritus and jetsam left behind, and I
was right.  kdelibs5 (for KDE 4) was still installed -- together
with kdelibs4 (for KDE 3.5). [Clever numbering -- ehhh?]  I did
`apt-get remove` for it, and everything continued to work.

A `locate -i kde4` showed me a few files and directories that
remained.  Slowly, one-by-one, I'm removing them by hand.
Everything continues to work.

OBTW, FWIW, I symlink'd $HOME/.kde to $HOME/.kde3 :
  lrwxrwxrwx  1 jonesy      5 2009-12-27 11:03 .kde -> .kde3
  drwx------  4 jonesy   4096 2009-12-27 10:45 .kde3
This solved a problem I had on my Ubuntu 9.10 workstation that
I installed KDE 3.5 on.  It solved a problem with some application -- 
a problem I can no longer describe (faulty organic memory bank.)

HTH ... somebody.
  Marvin L Jones    | jonz          | W3DHJ  | linux
   38.24N  104.55W  |  @ | Jonesy |  OS/2
    * Killfiling google &

More information about the ubuntu-users mailing list