testing out next ubuntu distribution

Tom H tomh0665 at gmail.com
Fri Feb 5 22:48:33 UTC 2010

>> > I made a small partition (but large enough) to test out ubuntu 10.04
>> > (64-bit),
>> > installed it there, and it worked, some time. Then when there apparently
>> > was
>> > some errors in
>> > new updates, gnome stopped to start, and the start process dumps me in a
>> > shell. Today I did
>> > sudo apt-get upgrade
>> > which took some time and downloaded and installed a lot,
>> > but I am still dumped in a shell. ¿What to do to get gnome back?

>> I upgraded a Karmic install to Lucid two days ago and had the same
>> issue. You can launch gnome with startx.

>> The problem turned out to be that gdm had been uninstalled because of
>> a conflict with usplash (IIRC).

>> Run
>> aptitude full-upgrade
>> and gdm will be re-installed.

> Thanks. I did aptitude full-upgrade, which resulted in a lot of activity.
> Then I did     startx
> which apparently "worked" (no error messages) but did'nt give me anything
> else
> than a shell, apparently (with smaller script!)

> Then I restyarted the pc, and now the kernel 2-6-32-12  did' ny even drop me
> into a shell!

> Restarting again, kernel 2-6-32-12-recovery mode works, I run dpkg, which
> did use some time and did
> something, but I can still not start as before.

> Any other suggestions, apart from starting from scratch?

Can you boot using the older kernel? Can you boot in single-user mode
in any kernel?

if you can, log in and run
dpkg --configure -a
aptitude update
aptitude install -f
aptitude safe-upgrade
aptitude full-upgrade

More information about the ubuntu-users mailing list