sudo with virsh

scar scar at
Tue Feb 2 20:59:55 UTC 2010

Hash: SHA256

Markus Schönhaber @ 02/01/2010 11:37 AM:
> 01.02.2010 18:11, scar:
>> ok, this is interesting.  everything works as expected when i am at the
>> console of the KVM/Qemu server.  i can use virsh and virt-manager
>> without sudo.  'groups' command lists me as being a member of libvirtd.
>> however, the need for sudo arises when i am on a remote system,
>> connected to the KVM/Qemu server via SSH.  'groups' command does not
>> list me as being a member of libvirtd when i am connected via SSH.  i am
>> connecting from a system on the same local network.
> I wouldn't expect to see any difference between a local and a ssh login
> wrt to libvirt or group membership. And indeed, I don't see any
> difference (I just tried - just in case...).

i rebooted the machine that i was SSH'ing from (that is the only thing i
can think of that has changed), and now when i SSH to the KVM host
machine, 'groups' now does reflect that i am a member of the libvirtd
group.  i can now also use virsh virt-manager without sudo to manage the
VM.  so, problem solved!  although i didn't figure what the root of the
problem was, unfortunately.



More information about the ubuntu-users mailing list