Andriod on Ubuntu Lucid

Chadley Wilson chadleyw at
Tue Aug 31 11:59:56 UTC 2010

> -----Original Message-----
> From: ubuntu-users-bounces at [mailto:ubuntu-users-
> bounces at] On Behalf Of Jordon Bedwell
> Sent: 31 August 2010 01:37 PM
> To: ubuntu-users at
> Subject: Re: Andriod on Ubuntu Lucid
> On 08/31/2010 05:50 AM, Chadley Wilson wrote:
> > Hi All,
> >
> > The android list takes way tooo long to respond.
> >
> > Has anyone here got experience with Android, and would be prepared to
> help me setup the build environment on Ubuntu Lucid 64bit?
> >
> An R&D guy who couldn't Google Ubuntu+Android how-to? I just find it
> intriguing is why I bring it up =P, now,  that aside, what exactly do you want
> to know? I brick and unbrick my Droids almost everyday. And why would you
> need to "build an environment"? Or you mean simply setup the software
> and prepare your machine to do it?

I assume you found a bunch of useful and up-to-date posts that apply specifically to Lucid 64?
As apposed all the stuff I can find being related to Ubuntu 8.xx 9.xx and Android 1.6 - 2.1 but very little on 2.2 vs. Ubuntu Lucid 10.04 64bit ;(

To answer your question,  Yes the mission is to prepare my machine to do it. I have never worked with android and do need some help with both terminology and the "machine preparations"
If I can just get the basic Android to build, I should be fine with the rest. Let's just say I need a bit help finding my way around Android.


I have run repo sync,  all is well.

I am now stuck with a few unknowns. Firstly running make starts with an error:
Find:  `drm/java` : no such file or directory

I have installed Java6 it is there and I have run java --version to establish that.

The build seems to continue and then stops with an error:

In file included from /usr/include/features.h:378,
                 from /usr/include/stdlib.h:25,
                 from build/tools/acp/acp.c:11:
/usr/include/gnu/stubs.h:7:27: error: gnu/stubs-32.h: No such file or directory
make: *** [out/host/linux-x86/obj/EXECUTABLES/acp_intermediates/acp.o] Error 1
chadley at JHB-WILSONCUB64:~/mydroid$

So I know I need the install x86 binaries, gclibc6-dev being one of them. But can't seem to locate a list of what and where to get them from?

So where to from here?

Chadley Wilson | Engineer
Research and Development | Pinnacle Africa

Pinnacle Technology Holdings E-Mail Disclaimer:

This e-mail is confidential and intended solely for the use of the individual(s) to whom it is addressed. Any views or opinions presented are solely those of the author and do not necessarily represent those of Pinnacle Technology Holdings any of it's divisions or affiliates. If you are not the intended recipient, be advised that you have this e-mail in error and that any use, dissemination, forwarding, printing, or copying of it is strictly prohibited.

More information about the ubuntu-users mailing list