No Connection

Ted Hilts ehilts at mcsnet.ca
Fri Apr 23 22:54:12 UTC 2010


On Fri, 2010-04-23 at 15:26 -0400, J wrote:
> On Fri, Apr 23, 2010 at 15:14, Ted Hilts <ehilts at mcsnet.ca> wrote:
> > I have this Linux machine that suddenly lost it's connection to the
> > Internet. I was running Lucid(installed) so I tried several other Ubuntu
> > LIVE releases like Karmic Koaoa (9.10), Jaunty Jackalopes (9.04) but
> > they all behaved in the same way -- that is NO CONNECTION.  Originally
> > at the time of the failure I had  been using the LAN connection which is
> > part of the CPU board.  So I removed the wire LAN cable from the socket
> > and added a LAN Card which goes into the computer bus.  But the same
> > problem persists.  All the LIVE machines still had the same problem --
> > NO CONNECTION even though it was enabled.  I have tried shutting down
> > and restarting. At first I thought the problem was hardware but the LAN
> > card is okay -- I took it from another Linux computer.  So now I think
> > something in the software is blocking the usual processes especially
> > because there is absolutely NO output data coming out of the "route -n"
> > command.
> 
> Silly question, but you see the same behaviour on several versions
> (Karmic, Lucid and Jaunty), both live and installed.
> 
> Can your other computers get out to the internet?  Are you sure your
> router/cable modem/network infrastructure is working?
> 
> Have you tried resetting your gateway (dsl router or cable modem)?
> 
> Just the basics there... if this were only happening on the Lucid
> installation, I'd suspect you'd broken something, but since you say
> you also booted the Live images for both Karmic and Jaunty (which will
> NOT be affected to whatever changes you made to your Lucid install),
> you need to look elsewhere for starters... (be it the hardware, cables
> unplugged, router gone nuts, cable company cut a line, whatever).
> 
> How about this, foregoing any mucking with network settings, can you
> plug this failing machine directly into your DSL router or cable modem
> (means disconnecting the rest of your lan) and then boot the LIVE
> image for any of those, get an address from your router or cable
> modem, and surf the internet?
> 
> That would probably be my first step, after checking cables and such,
> given what you've described.

Did everyone of those things you said plus other things with one
exception, I can,t make this machine the sole owner of the router.
However, I plugged the problem machine directly into the router instead
of into the 12 slot HUB -- absolutely no difference.  All the other
machines are working fine and using the local network as well the the
Internet network.  Since your email I looked up the Man stuff for the
command "route" and built a route table which I tried to make the same
as the Linux machine on which I am writing this email.  One table entry
is OFF and needs to be redone for it to be the same. Also, the metrics
are not in the table.  Never did this before but there should have been
something happen. The point I am making is that the table made NO
difference. The last entry in the route table is the URL for the router
so if the problem machine can't pick up on that it would seem the
problem is all together different.

Too bad there isn't a repair kit. 

Thanks -- Ted Hilts






More information about the ubuntu-users mailing list