No Connection

Ted Hilts ehilts at
Fri Apr 23 19:14:12 UTC 2010

I have this Linux machine that suddenly lost it's connection to the
Internet. I was running Lucid(installed) so I tried several other Ubuntu
LIVE releases like Karmic Koaoa (9.10), Jaunty Jackalopes (9.04) but
they all behaved in the same way -- that is NO CONNECTION.  Originally
at the time of the failure I had  been using the LAN connection which is
part of the CPU board.  So I removed the wire LAN cable from the socket
and added a LAN Card which goes into the computer bus.  But the same
problem persists.  All the LIVE machines still had the same problem --
NO CONNECTION even though it was enabled.  I have tried shutting down
and restarting. At first I thought the problem was hardware but the LAN
card is okay -- I took it from another Linux computer.  So now I think
something in the software is blocking the usual processes especially
because there is absolutely NO output data coming out of the "route -n"

I used ifconfig and route and all Live machines as well as Lucid
(installed) could see eth0 and eth1 but there was no output from the
route command. I cannot disable the two WIRE CONNECTIONS from appearing
on the ifconfig output but I can edit out from the connection form
either or both. I had a problem like this once before on MS XP machine
and I had to disable one of the two connections before the problem would
go away. I tried "sudo route add default gw (router address)
dev eth1" but that did't work.  I don't care which connection works but
neither of the two will not make a connection to the internet.
Everything else seems to be working on this Linux machine.  It is just
the connection issue.  

At the time of the loss of connection I was adding static addresses so
this machine could interact with other Linux machines I
changed /etc/samba/smb.conf and added static addresses to /etc/hosts.
But when I lost connection I rolled back to the originals and still no
connection. When the Lucid machine was installed the installation
activated the DHCP resulting in url which range (at or
over 100) was reserved for DHCP. I did not expect the DHCP to kick in.
The range 0-99 is reserved for static addressed. So maybe there is some
undone situation that affects all Ubuntu distributions. I am thinking
this way because there is NO data coming from the "route" command so
obviously there can be NO connection. So what happened to the connection
data that must somehow underlie the automatic connection process?  And
how do I restore that situation? 

I hope someone out there knows a way around this problem. Somewhere in
the Linux command structure I remember there were some commands that set
up connectivity but I can't find them now.

Thanks -- Ted Hilts

More information about the ubuntu-users mailing list