gmusicbrowser broken yesterday (will not run)

nepal nepal.roade at googlemail.com
Wed Apr 21 15:03:57 UTC 2010


Are there any other gmusicbrowser users that have had 'gmb' broken by
an update either yesterday (tues) or mon 19/4?

Unusually, I did'nt play any music yesterday and so am not sure when it
happened, but I know for definite I did play music with 'gmb' on monday.
The error may be related to a perl update, but I don't know enough... 

The problem is the application will not run from an icon. So I tried
running it from a terminal and this is the error messages I'm getting.

==========================================
nepal at nepal-ubu:~$ gmusicbrowser
Reading saved tags in /home/nepal/.config/gmusicbrowser/tags ...
skipping invalid song entry : 
Reading saved tags in /home/nepal/.config/gmusicbrowser/tags ... done
Use of uninitialized value $col in string eq at /usr/bin/gmusicbrowser
line 8181. Use of uninitialized value $cmd in hash element
at /usr/bin/gmusicbrowser line 8183. Use of uninitialized value in
subroutine entry at /usr/bin/gmusicbrowser line 8183. Can't use string
("") as a subroutine ref while "strict refs" in use
at /usr/bin/gmusicbrowser line 8183. nepal at nepal-ubu:~$ ^C
nepal at nepal-ubu:~$ 
==========================================

AFAICT there has been no update to 'gmb' and I have not done anything
knowingly to create this problem. Anyone understand what this is and
what can be done to correct it?

TIA

nepal.

p.s. I have tried re-installing.




More information about the ubuntu-users mailing list