[resolved] Re: [karmic] openssl failed to upgrade

NoOp glgxg at sbcglobal.net
Fri Apr 9 16:19:43 UTC 2010


On 04/08/2010 08:03 PM, NoOp wrote:
> I've a machine that I performed a karmic upgrade on that results in a
> broken openssl package. Filed a bug report:
> <https://bugs.launchpad.net/ubuntu/+source/openssl/+bug/557641>
> [package openssl 0.9.8g-16ubuntu3.1 failed to install/upgrade: failed in
> buffer_read(fd): md5hash]
> but no joy.
> 
> I hesitate to trust the machine further until the problem is resolved
> given the security possibilities. Any advise on how to fix this?

Finally resolved by downloading the .deb and:

$ sudo dpgk -i --force-all openssl_0.9.8g-16ubuntu3.1_i386.deb

Not the way that I would have wished to fix it, but I suspect that the
dpkg & md5hash may have gotten corrupted during a recent power failure.





More information about the ubuntu-users mailing list