flaky resolution and aspect ratio

Thufir hawat.thufir at gmail.com
Sat Apr 3 22:23:36 UTC 2010

I'm not entirely sure of the resolution settings, but they're flaky.  
Quite often the aspect ratio seems off like when they broadcast old 
movies for tv the image is stretched vertically (or, like viewing HD tv 
on regular tv).  Often logging out will fix the problem by, I presume, 
restarting x windows.

How do I log or capture this?  I suppose I can grab a screenshot, but 
surely in dmesg or similar there would be an event along the lines of 
"not detecting video card correctly, trying defaults..." (assuming that 
to be the source of the problem).

I don't see how it's a matter of changing the screen resolution in X 
windows, since quite often, the resolution and aspect ratio are fine.  
Perhaps it's flaky hardware?

Or, maybe a driver that's not always loading correctly?  Although that 
would be inconsistent with logging out fixing the problem.  A few days 
ago logging out and logging back in stopped fixing it, and it's annoying, 

thufir at ARRAKIS:~$ 
thufir at ARRAKIS:~$ lspci
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 661FX/M661FX/M661MX 
Host (rev 11)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SiS AGP Port 
(virtual PCI-to-PCI bridge)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS964 [MuTIOL Media 
IO] (rev 36)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev 
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] 
AC'97 Sound Controller (rev a0)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 
Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 
Controller (rev 0f)
00:03.2 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 
Controller (rev 0f)
00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 
00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 PCI 
Fast Ethernet (rev 91)
00:05.0 IDE interface: Silicon Integrated Systems [SiS] RAID bus 
controller 180 SATA/PATA  [SiS] (rev 01)
00:09.0 Ethernet controller: D-Link System Inc RTL8139 Ethernet (rev 10)
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 
661/741/760 PCI/AGP or 662/761Gx PCIE VGA Display Adapter
thufir at ARRAKIS:~$ 
thufir at ARRAKIS:~$ nl /etc/X11/xorg.conf
     1	# xorg.conf (X.Org X Window System server configuration file)
     2	#
     3	# This file was generated by dexconf, the Debian X Configuration 
tool, using
     4	# values from the debconf database.
     5	#
     6	# Edit this file with caution, and see the xorg.conf manual page.
     7	# (Type "man xorg.conf" at the shell prompt.)
     8	#
     9	# This file is automatically updated on xserver-xorg package 
upgrades *only*
    10	# if it has not been modified since the last upgrade of the 
    11	# package.
    12	#
    13	# Note that some configuration settings that could be done 
    14	# in this file, now are automatically configured by the server 
and settings
    15	# here are ignored.
    16	#
    17	# If you have edited this file but would like it to be 
automatically updated
    18	# again, run the following command:
    19	#   sudo dpkg-reconfigure -phigh xserver-xorg
    20	Section "Device"
    21		Identifier	"Configured Video Device"
    22	EndSection
    23	Section "Monitor"
    24		Identifier	"Configured Monitor"
    25	EndSection
    26	Section "ServerFlags"
    27	        Option          "DontZap"               "false"
    28	EndSection
    29	Section "Screen"
    30		Identifier	"Default Screen"
    31		Monitor		"Configured Monitor"
    32		Device		"Configured Video Device"
    33	EndSection
thufir at ARRAKIS:~$ 

Also, I tried to disable dontZap, but it still doesn't seem to work.  


(upgrading, but doubtful that this will fix the problem)

More information about the ubuntu-users mailing list