Can't Get Broadcom bcm4312 driver to work at all on Dell Inspiron 15n

R. A. Bilonick rab at consolidated.net
Thu Apr 1 13:29:34 UTC 2010


On Thu, 2010-04-01 at 12:30 +0200, Stefano Negro wrote:
> 
> 
> 2010/4/1 R. A. Bilonick <rab at consolidated.net>
>         I forgot to mention that when I compiled the driver from the
>         bcm web
>         site, it did create a eth2 device which shows up using
>         ifconfig. But
>         neither network-manager nor wicd see it (they don't show any
>         wireless
>         networks).
>         
>         
>         --
>         ubuntu-users mailing list
>         ubuntu-users at lists.ubuntu.com
>         Modify settings or unsubscribe at:
>         https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
> 
> I can confirm what you say.
> On jaunty "Hardware Drivers" shows "Broadcom STA wireless driver" and
> selecting it it's succesfully activated.
> I'll try to follow the wiki and I'll let you know.
> https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx
> If you find something please tell me.
> 
> -- 
> Bye
> Stefano

After installing wicd on my Dell laptop, I still couldn't see any
wireless networks. I rebooted and still nothing. I removed the driver
and tried re-installing but there seemed to be problems and no wireless.
I shutdown this morning and came to work. When I turned on the laptop,
lo and behold, I can see all the wireless networks here.

I'm not sure why this is now so difficult under 9.10. It worked
flawlessly under 9.04 (well almost, I needed wicd to get wpa2). If I
boot from the Knoppix 6.2 LiveCD, it boots up and sets up the wireless
without me having to do anything (nothing, nada).

Under 9.10, it seems it will work if you just fiddle enough (even if you
don't really understand all the details). Patience does seem to pay off
if you try long enough.

Thanks. I hope it works out for you.

Rick B.





More information about the ubuntu-users mailing list