CUPS Printer Support Not Working...

Nils Kassube kassube at gmx.net
Thu Sep 24 06:37:03 BST 2009


Graham Todd wrote:
> Nils Kassube <kassube at gmx.net> uttered these words:
> > The hplip driver coming with Jaunty is broken. It doesn't provide
> > the necessary step to allow you to accept the lisence for the
> > proprietary driver needed for your printer. Please download and
> > install the latest version of the hplip package from [1].
>
> Does this mean that the driver which comes with Jaunty is not free
> software, or only the broken one is free software, but being broken
> it won't work so the only available is the proprietary driver which
> requires you to accept a non-free licence?

The hplip package is free / open source software (look at 
hplipopensource.com if you want to know the exact licence terms). 
However many new HP printers need an additional proprietary driver. The 
hplip package is supposed to download and install the printer driver if 
necessary, i.e. if you have such a new printer. That driver wants you to 
accept their EULA but the broken Jaunty version doesn't ask you (the 
Karmic version does ask) and therefore can't install the driver.


Nils





More information about the ubuntu-users mailing list