problem upgrading my system

Leonard Chatagnier lenc5570 at
Tue Sep 1 12:59:12 UTC 2009

--- On Tue, 9/1/09, Luca Ferrari <fluca1978 at> wrote:

> From: Luca Ferrari <fluca1978 at>
> Subject: problem upgrading my system
> To: "Ubuntu user technical support, not for general discussions" <ubuntu-users at>
> Date: Tuesday, September 1, 2009, 3:45 AM
> Hi all,
> from a few days when I try to upgrade my system I got an
> apt problem related 
> to libindi:
> Unpacking libindi0 (from
> .../libindi0_0.6-0ubuntu1_amd64.deb) ...
> dpkg: error processing
> /var/cache/apt/archives/libindi0_0.6-0ubuntu1_amd64.deb 
> (--unpack):
>  trying to overwrite `/usr/bin/indiserver', which is also
> in package indi
> Errors were encountered while processing:
>  /var/cache/apt/archives/libindi0_0.6-0ubuntu1_amd64.deb
> E: Sub-process /usr/bin/dpkg returned an error code (1)
> However I cannot solve it running apt-get -f install and I
> cannot uninstall 
> libindi because kstars depends on it, kdeedu depends on
> kstars and kde depends 
> on kdeedu. What can I do?
> Thanks,
> Luca
This issue was discussed and resolved in the August
archives.  See this subject in the August archives:

Re: KDE 4.3 PPA Install In Jaunty-Dependencies Issues[SOLVED]
Sunday, August 16, 2009 10:59 PM
I suggest you review the thread but the quick
answer is to remove "indi" and install libindi0:
Use "sudo dpkg -r indi" and "sudo aptitude install libindi0"
Note the it's a zero and not an O in libindi0.
I don't know why you need dpkg -r to remove indi
Instead of using aptitude remove but that's what 
worked for me.  There were several links give by
NoOp in that thread on the issue so if the one I 
used doesn't work for you, one of the others should.
Leonard Chatagnier
lenc5570 at

More information about the ubuntu-users mailing list