wicd asks for password before connecting after upgrade to karmic

Ray Leventhal ubuntu at swhi.net
Mon Nov 2 19:26:37 UTC 2009

Hi all,

I've solved this, but in a klunky way.  Just wanted to put it out there 
in case there are others who hit a roadblock and perhaps to tweak the 
nice folks who know more than I to reveal a better, less klunky solution.

Running Jaunty, fully updated.  wicd as installed nm.

Update to Karmic via alternate-cd mounted image.  All goes well, but on 
reboot, wicd requires password (wired connection, no wireless on this 
box).  I provide password, but have to stop and restart wicd to get 
packets to pass.

A review of google results and the forums talk about something similar 
from Intrepid to Jaunty upgrade, involving the /etc/init.d/wicd script, 
but that was not the issue.  I'm guessing that wicd wasn't starting 
properly, and tried to after the GUI came up.  Clientside working, 
daemon not...

Anyway, I re-mounted the karmic-alternate cd image, did sudo apt-get 
install network-manager, which removed wicd, then after reboot 
(required, or so it said), I did sudo apt-get install wicd and all is well.

This one's for the archives, in case anyone runs into this trouble...I'm 
sure there's a more elegant solution, but this worked for me.

HTH someone,

A: Because it messes up the order in which people normally read text.
Q: Why is top-posting such a bad thing?
A: Top-posting.
Q: What is the most annoying thing in e-mail?
()  ascii ribbon campaign - against html e-mail
/\  www.asciiribbon.org   - against proprietary attachments

More information about the ubuntu-users mailing list