Firefox not working in 9.10

NoOp glgxg at
Sun Nov 1 18:16:04 UTC 2009

On 11/01/2009 12:16 PM, Harry Paterson wrote:
> Hi everybody,
>                        Cleaned out my Ubuntu desktop and reinstalled  
> 9.04 and everything worked fine.
> Did the upgrade to 9.10 and Firefox still will not get on line. Exactly 
> the same as when I installed
> 9.10 from the .iso download.
>   Any helpful suggestions ?

Did does "9.04 and everything worked fine" mean Fx worked in 9.04 before
you did the upgrade?

Can you ping,, etc from the terminal?
Does the Network Manager indicate that you are getting an IP? Move the
mouse over the NM icon on the panel, right-click, click 'Connection
Information'. Also provide the results from the terminal output:
$ ifconfig
$ cat /etc/hosts
$ cat /resolv.conf
$ cat /etc/network/interfaces

I had one nic that for some reason didn't work in 9.10 (worked just fine
in 8.04). I finally ended up installing newer drivers for it from within
Windows (it's a dual-boot test machine), and for some weird reason, it
started working in 9.10. The only thing I can guess is that the newer
win drivers fixed a bug in the nic firmware. The nic is an onboard Intel
82801BA/BAM/CA/CAM Ethernet Controller that also didn't play well with a
half-duplex ethernet hub in 9.10.

More information about the ubuntu-users mailing list