kcalc dependencies

Derek Broughton derek at pointerstop.ca
Sat Mar 21 01:27:45 UTC 2009


Greg White wrote:

> @H.S.:
> # aptitude show kcalc
> Depends: kdebase-runtime (>= 4:4.1.3), kdelibs5 (>= 4:4.1.4), libc6 (>=
> 2.1.3),
>          libgmp3c2, libqt4-xml (>= 4.4.3), libqtcore4 (>= 4.4.3),
>          libqtgui4 (>= 4.4.3), libstdc++6 (>= 4.1.1)
> 
> From my /var/cache/apt/archives/
> kdebase-runtime-data_4%3a4.1.4-0ubuntu1~intrepid1.1_all.deb
> kdebase-runtime-data-common_4%3a4.1.4-0ubuntu1~intrepid1.1_all.deb
> kdebase-runtime-data-common-kde3_4%3a3.5.10-0ubuntu4~intrepid0_all.deb
> 
> How can I have the runtime-data but not runtime???
> How can I tell what packages I have installed??

No, that says you have those packages in the cache - not that they're
installed. 

# aptitude show kdebase-runtime-data

would tell you if it's installed

> @Derek Broughton:
> # apt-get -f install
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> 0 upgraded, 0 newly installed, 0 to remove and 31 not upgraded.

Bingo.  That's telling you that you still have 31 packages waiting to be
upgraded.  Like "gstreamer"...
> 
> @NoOp:
> I don't use gnome.  I use KDE.  It has been working fine until now.

I beg to differ - you _have_ gnome packages installed.  Nothing KDE asks
for "gvfs".  You don't need to have the Gnome desktop installed - just one
gnome package will start pulling in those dependencies.
-- 
derek





More information about the ubuntu-users mailing list