can't install cowpatty under 8.10

Nicolae Ghimbovschi xfreebird at gmail.com
Sun Mar 15 11:58:46 UTC 2009


You need to install openssl devel package

On Sun, Mar 15, 2009 at 13:39, 刘先良 <521liuxianliang at 163.com> wrote:
> i want to install cowpatty ,but when i "make" there's something wrong!
> here is the details:
>
> ethan at King-laptop:~/cowpatty-4.3$ make
> cc -pipe -Wall -DOPENSSL  -O2 -g3 -ggdb   -c -o md5.o md5.c
> md5.c:20:25: error: openssl/md5.h: No such file or directory
> md5.c: In function 'md5_mac':
> md5.c:28: error: 'MD5_CTX' undeclared (first use in this function)
> md5.c:28: error: (Each undeclared identifier is reported only once
> md5.c:28: error: for each function it appears in.)
> md5.c:28: error: expected ';' before 'context'
> md5.c:29: warning: implicit declaration of function 'MD5_Init'
> md5.c:29: error: 'context' undeclared (first use in this function)
> md5.c:30: warning: implicit declaration of function 'MD5_Update'
> md5.c:33: warning: implicit declaration of function 'MD5_Final'
> md5.c: In function 'hmac_md5_vector':
> md5.c:40: error: 'MD5_CTX' undeclared (first use in this function)
> md5.c:40: error: expected ';' before 'context'
> md5.c:48: error: 'context' undeclared (first use in this function)
> make: *** [md5.o] Error 1
>
> i have installed openssl and "aptitude install libssl-dev", who can help
> me?
>
> ps: cowpatty come from http://www.willhackforsushi.com/Cowpatty.html
>
>
>
> --
> ubuntu-users mailing list
> ubuntu-users at lists.ubuntu.com
> Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
>




More information about the ubuntu-users mailing list