Samba problem, does not show files [SOLVED]

Lorenzo Luengo lluengo at
Thu Mar 5 19:05:15 UTC 2009

Derek Broughton escribió:
>> This is not a samba problem. You need chmod go+x in Andres and
>> Biblioteca if you want users in fileshare and everyone else to access
>> that directory.
> Or of course just "g+x" if you just want everybody in "fileshare" group to
> be able to list the directory contents.
Cool! it just worked smoothly!!! :D
>>> I still keep thinking it's a bug.
>> It's a feature.
> It's a kludge :-)  That is, the "x" attribute is overloaded and only
> means "eXecute" when the object is a file; it means "allow reading of the
> directory contents - "aXxess" :-) - on directories.
> But it's a kludge that dates back to the very earliest days of Unix, and it
> can hardly be changed at this point.  In any case, it beats some of the
> really odd things Windows does with permission attributes...
:S I didn't know of this "feature". I always thought that the 'x' 
permission only was meaningful for files.

Thanks everyone that helped building on this solution!

Lorenzo Luengo Contreras
Administrador de Sistemas DGEO
Universidad de Concepción
Concepción - Chile

More information about the ubuntu-users mailing list