What pgm reads the /etc/network/interfaces file? (Installation WPA worked great! Too bad I messed with it!)

NoOp glgxg at sbcglobal.net
Sun Jun 28 18:13:30 UTC 2009

On 06/27/2009 01:55 PM, cts.private at yahoo.com wrote:
> After installing Ubuntu 8.04 (from 2008/06/14) my wireless worked
> great.  But then I noticed it was picking up its IP address from DHCP
> so I changed it to static.  At least, that's all I remember doing.
> Anyway, now Ubuntu doesn't connect to my WIFI router anymore when I
> start the system.
> I have to re-enter the WPA key into the nm-applet - about 12
> clear-text characters, and then everything works fine again.  But the
> next time I start Ubuntu, the 12 dots are replaced with enough dots
> to cover the encrypted version (which has been encrypted correctly
> and stored in /etc/network/interfaces) - when I re-enter the
> clear-text (which is covered by dots), I'm connected again.
> It's like, the system is taking the argument to wpa-psk (as written
> by nm-applet) as if it it's clear text!

There are issues with NM:
[Wireless WPA key corrupted]
[seahorse does not show original wpa passphrase]
[WPA password changes into hash, not properly stored]

Were I you, I'd look into installing wicd...

More information about the ubuntu-users mailing list