What pgm reads the /etc/network/interfaces file? (Installation WPA worked great! Too bad I messed with it!)

cts.private at yahoo.com cts.private at yahoo.com
Sat Jun 27 20:55:17 UTC 2009

After installing Ubuntu 8.04 (from 2008/06/14) my wireless worked great.  But then I noticed it was picking up its IP address from DHCP so I changed it to static.  At least, that's all I remember doing.

Anyway, now Ubuntu doesn't connect to my WIFI router anymore when I start the system.

I have to re-enter the WPA key into the nm-applet - about 12 clear-text characters, and then everything works fine again.  But the next time I start Ubuntu, the 12 dots are replaced with enough dots to cover the encrypted version (which has been encrypted correctly and stored in /etc/network/interfaces) - when I re-enter the clear-text (which is covered by dots), I'm connected again.

It's like, the system is taking the argument to wpa-psk (as written by nm-applet) as if it it's clear text!


More information about the ubuntu-users mailing list