wicd, static IP address, adsl modem and pppoe mode

H.S. hs.samix at gmail.com
Wed Jun 3 19:32:55 UTC 2009

NoOp wrote:
> On 06/03/2009 08:33 AM, H.S. wrote:
>> Hello,
>> On a Ubuntu machine, I used to have network manager in Hardy in which I
>> had set the IP address of the machine to be a static one.
>> The machine's eth0 network cad is connected to an adsl modem working in
>> pppoe mode. So when the modem is switched on, the internet connection is
>> established with the ISP.
>> When there was hardy installed and nm-applet was being used, it didn't
>> matter when I switched on the computer, before or after switching on the
>> modem, the networking in computer worked fine.
>> But now I am using wicd in Jaunty. I have configured the static ip
>> address in wicd. But the few times I have rebooted the computer yet, the
>> internet connection in the computer does not work unless the adsl modem
>> was already switched on. What gives? Is wicd somehow the culprit? Looks
>> like it demands the modem to be already on when it starts up. Or am I
>> missing something here?
>> Thanks.
> What does it show in the wicd manager after you click the wicd icon?
> Does clicking the 'Connect' button refresh & work?
> I tried to replicate by removing my wifi card and the lan cable.
> Rebooted and of course wicd is showing no connection; however as soon as
> I plugged in the wired cable (this goes to my router that is set for
> ppoe), I instantly am connected and issue my fixed IP address.
> Click on your wired network setting and check to see that 'Use as
> default...' is set, and then 'Advanced Settings'. In AS I have:
> Use Static IP's checked
> - IP = my fixed IP address
> - Netmask =
> - Gateway = my routers IP
> - DNS1 = my routers IP
> For gateway & DNS1-3 you'll need to set the appropriate addresses for
> your ISP of course.
> You might want to also select 'Preferences' and under General Settings
> check:
> - Automatically reconnect on connections loss
> - Use default profile on wired connect.

I checked these already and seem to be similar to your settings. Thanks
for confirming though that it works for you. I will see what else could
be wrong. This is on a newly installed Jaunty machine and I might be
missing something.


More information about the ubuntu-users mailing list