What happens if you forget to create a primary partition?

Alexandra Zaharia f0rg3r at gmail.com
Wed Jun 3 13:38:01 UTC 2009

2009/6/3 Markus Schönhaber <ubuntu-users at list-post.mks-mail.de>:

>> And by useless I mean really, totally, terminally useless: I can't
>> even see anything for it when I plug it in (via the USB interface) in
>> /var/log/messages.
> No matter how you partitioned the drive, the kernel should still, at
> least, report the plugged in USB device.

I know. It did, when I was trying various 1 or 2 primary partitions

After I created only the extended one, it stopped showing anything in
/var/log/messages (and believe me, I was monitoring that all the

> Depending on what those "file system creation errors" exactly were, they
> may already have been symptoms of a drive going faulty.

Well, first off, this external HDD is brand new, I bought it
yesterday. It was formatted and partitioned for Mac. Simple, I
thought. I used fdisk to create 1 single primary partition and I
assigned it type 83 (Linux).

When I went on and used mkfs.ext3 to create a file system on it, I got
near the end:

ext2fs_mkdir Attempt to read block from filesystem resulted in short
read while creating root dir

I thought it might be something related to ext3 (although I know it
should be able to handle partitions much larger than 1 TB).

So I gave it another shot with ReiserFS. The partition was created
fine (and very fast) but it was locking up when I was writing on the
drive. (A "mv" operation that was freezing.)

Then I decided to test more combinations involving ext3 since I never
actually used ReiserFS.

The setups I tried were:

1 primary partition - 1 TB (ext3)
1 primary partition - 1 GB (ext3) and 1 primary partition - the rest (ext3)
1 primary partition - 1 GB (ext3) and 1 logical partition - the rest (ext3)
1 primary partition - 500 GB (ext3) and 1 primary partition - the rest (ext3)

My testing stopped when I accidentally did:

1 extendend partition - 1 TB with 1 logical partition - 500 GB (ext3)

I got the same ext2fs_mkdir error and when I tried for the n-th time
to plug out and plug in again the drive, nothing was appearing anymore
in /var/log/messages.

I tried resets and so on, to no avail.

> The first thing I'd do is change the USB cable. If that doesn't improve
> things, I'd try to connect the drive to another machine. If it's not
> working there either, I'd contact the vendor for replacement.

Aye, I have a laptop and a desktop, it's the same on both machines.

As for the cable, it's the exact type that my photo camera uses so I
tried that one. Same thing...

On Wed, Jun 3, 2009 at 4:12 PM, Rashkae <ubuntu at tigershaunt.com> wrote:

> Partitioning a drive with only an Extended partition is perfectly
> normal.  I would surmise, purely by unsubstantiated conjecture, that
> your file creation errors were from a malfunctioning drive, and now that
> path has simply come to it's natural end.

It is? Wow, whew! I was afraid I've done the most stupid thing ever.

Thank you both for your replies.

I'm still amazed at the thought it would be possible to be a
malfunctioning drive, since I unsealed its case yesterday (and until
now I've been quite fond of Western Digital's high quality and
reliable drives). Thing is, I never bought an external HDD from them,
to be honest.

I will try to contact their support although I have a feeling they
won't like me telling them I tried to write a Linux partition table on
their designed-for-Mac hard drives.

More information about the ubuntu-users mailing list