32-bit OpenGL library segfaults.

Muzer muzerakascooby at gmail.com
Tue Jun 2 13:57:15 UTC 2009


Hello,

I have Kubuntu 9.04 installed with the proprietary nvidia driver. Most 
things work fine (apart from the fact that plasma seems a bit unstable, 
but I can live with it as it usually just takes a killall plasma && 
plasma to set it right), but there is one problem. When I try to run a 
pre-compiled 32-bit binary that uses OpenGL, I always get a segfault. I 
just thought this was a side-effect of running a 64-bit system, but I've 
noticed it doesn't happen to others, so that got me interested. When I 
ran both programs that don't work (RomCheckFail and Google Earth, FYI) 
with gdb, I got this output:

(this is from google earth).

muzer at muzer-desktop:/usr/lib32/googleearth$ gdb ./googleearth-bin
GNU gdb 6.8-debian                                               
Copyright (C) 2008 Free Software Foundation, Inc.                
License GPLv3+: GNU GPL version 3 or later 
<http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute 
it.          
There is NO WARRANTY, to the extent permitted by law.  Type "show 
copying"  
and "show warranty" for 
details.                                            
This GDB was configured as 
"x86_64-linux-gnu"...                            
(no debugging symbols 
found)                                                
(gdb) 
run                                                                   
Starting program: 
/usr/lib32/googleearth/googleearth-bin                    
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
[Thread debugging using libthread_db 
enabled]                               
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
---Type <return> to continue, or q <return> to 
quit---                      
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
---Type <return> to continue, or q <return> to 
quit---                      
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
(no debugging symbols 
found)                                                
[New Thread 0xf4a43700 (LWP 
15439)]                                         

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0xf4a43700 (LWP 15439)]       
0xf5a49ce6 in ?? () from /usr/lib32/libGL.so.1     
(gdb) bt                                           
#0  0xf5a49ce6 in ?? () from /usr/lib32/libGL.so.1 
Cannot access memory at address 0xd                
(gdb) q                                            
The program is running.  Exit anyway? (y or n) y   
muzer at muzer-desktop:/usr/lib32/googleearth$



In RomCheckFail, the values are a bit different:

muzer at muzer-desktop:/usr/lib32/googleearth$ gdb 
/opt/RomCheckFail/bin/RomCheckFail                    
GNU gdb 
6.8-debian                                                                                     

Copyright (C) 2008 Free Software Foundation, 
Inc.                                                     
License GPLv3+: GNU GPL version 3 or later 
<http://gnu.org/licenses/gpl.html>                         
This is free software: you are free to change and redistribute 
it.                                    
There is NO WARRANTY, to the extent permitted by law.  Type "show 
copying"                            
and "show warranty" for 
details.                                                                       

This GDB was configured as 
"x86_64-linux-gnu"...                                                      
(no debugging symbols 
found)                                                                           

(gdb) 
run                                                                                              

Starting program: 
/opt/RomCheckFail/bin/RomCheckFail                                                   

(no debugging symbols 
found)                                                                           

(no debugging symbols 
found)                                                                           

(no debugging symbols 
found)                                                                           

[Thread debugging using libthread_db 
enabled]                                                         
(no debugging symbols 
found)                                                                           

(no debugging symbols 
found)                                                                           

(no debugging symbols 
found)                                                                           

(no debugging symbols 
found)                                                                           

(no debugging symbols 
found)                                                                           

(no debugging symbols 
found)                                                                           

(no debugging symbols 
found)                                                                           

(no debugging symbols 
found)                                                                           

(no debugging symbols 
found)                                                                           

(no debugging symbols 
found)                                                                           

(no debugging symbols 
found)                                                                           

(no debugging symbols 
found)                                                                           

(no debugging symbols 
found)                                                                           

(no debugging symbols 
found)                                                                           

(no debugging symbols 
found)                                                                           

(no debugging symbols 
found)                                                                           

(no debugging symbols 
found)                                                                           

(no debugging symbols 
found)                                                                           

(no debugging symbols 
found)                                                                           

(no debugging symbols 
found)                                                                           

---Type <return> to continue, or q <return> to 
quit---                                                
(no debugging symbols 
found)                                                                           

(no debugging symbols 
found)                                                                           

(no debugging symbols 
found)                                                                           

(no debugging symbols 
found)                                                                           

(no debugging symbols 
found)                                                                           

[New Thread 0xf62d56c0 (LWP 
8773)]                                                                    

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0xf62d56c0 (LWP 8773)]        
0xf7379ce6 in ?? () from /usr/lib32/libGL.so.1     
(gdb)                                              
(gdb) exit                                         
Undefined command: "exit".  Try "help".            
(gdb) quit                                         
The program is running.  Exit anyway? (y or n) y   
muzer at muzer-desktop:/usr/lib32/googleearth$

The NVIDIA driver was installed using NVIDIA's own installer, because 
for some odd reason, jockey failed to notice I needed it.

Any ideas? Is my 32-bit OpenGL library just corrupted? Or is something 
weirder happening?

-- 
-----BEGIN GEEK CODE BLOCK-----
Version: 3.1
GCS/CM/IT d>++ s+:- a---- C+++ UL+++>++++ P+>+++ L+++>+++++ E---->--- W+++ N o? K? w--- O+ M-- V- PS PE? Y-- PGP- t+ 5? X- R-- tv+ b++ DI D G++ e- h! !r y 
------END GEEK CODE BLOCK------





More information about the ubuntu-users mailing list