PXE booting intrepid install cds

drew einhorn drew.einhorn at gmail.com
Thu Jan 29 17:53:11 GMT 2009


I'm PXE booting because I can't get the laptop into the bios to set it
to boot from cd.

After pondering

    https://wiki.edubuntu.org/LiveCDNetboot
    http://www.debian-administration.org/articles/478

I came up with a configuration that "almost" works.

I tried a couple different .isos

ubuntu-8.10-alternate-amd64.iso
ubuntu-8.10-desktop-amd64.iso

I tried the desktop cd first.  The livecd desktop comes up
screen loads and runs very sluggishly.

Sort of like when you try to do a remote install over a low bandwidth
connection.  or with bad remote access inftrastructure.

The install seems to be working but it's painfully slow waiting for the
screens to finish painting.  And if you get distracted and go do
something else, by the time you get back the screen is frozen.

Next I tried the alternate cd.  Starts working until it looks for
a cd drive with the installer.  Should be looking for the nfs mounted
installer instead.  Refuses to continue without the cd..

Here's /var/lib/tftpboot/

drew at drew5:/nfs/export/iso$ cd /var/lib/tftpboot/
drew at drew5:/var/lib/tftpboot$ ls -l
total 16708
-r--r--r-- 1 root root 5455356 2009-01-28 22:38 alternate_initrd.gz
-r--r--r-- 1 root root 9194840 2009-01-22 09:55 desktop_initrd.gz
-rw-r--r-- 1 root root   54704 2009-01-26 11:29 menu.c32
-rw-r--r-- 1 root root   14776 2009-01-26 11:21 pxelinux.0
drwxr-xr-x 2 root root    4096 2009-01-28 22:45 pxelinux.cfg
-r--r--r-- 1 root root 2339712 2009-01-22 09:55 vmlinuz
drew at drew5:/var/lib/tftpboot$

alternate_initrd.gz is a copy of ubuntu-8.10-alternate-amd64/install/initrd.gz
desktop_initrd.gz is a copy of ubuntu-8.10-desktop-amd64/casper/initrd.gz

vmlinuz is the same for both install cds

menu.c32 and pxelinux.0 are from /usr/lib/syslinux

pxelinux.cfg/default

# menu.c32 is in the syslinux package.  It will tftp load the
pxelinux.cfg config file itself, which can be useful when editting it.
default menu.c32
SAY press return for menu
#TIMEOUT 50

LABEL intrepid-desktop-amd64
        kernel vmlinuz
        append boot=casper netboot=nfs
nfsroot=192.168.3.50:/nfs/export/mnt/ubuntu-8.10-desktop-amd64
initrd=desktop_initrd.gz --

LABEL intrepid-alternate-amd64
        kernel vmlinuz
        append boot=install netboot=nfs
nfsroot=192.168.3.50:/nfs/export/mnt/ubuntu-8.10-alternate-amd64
initrd=alternate_initrd.gz --


Tried putting an alternate install cd in the drive to see how far it
gets to a red screen of death

[!!]Install the base system

Debootstrap Error

Failed to determine the codename for the release

Arghhh!!!

-- 
Drew Einhorn




More information about the ubuntu-users mailing list