Internet: browsers fails to connect to SOME sites, not all, for no reason.

Vincent Trouilliez vincent.trouilliez at
Wed Jan 28 07:44:21 UTC 2009

Nils Kassube <kassube at> wrote:
> Which browser? What is the exact error message?

Using Ubuntu 8.10.

My default browser is Epiphany (same backend as firefox).
It just says: "<site> could not be found", please check that you are
connected to the internet blah blah...

Firefox says:

Address Not Found
Firefox can't find the server at <site>
The browser could not find the host server for the provided address.

Elinks says: "unable to retrive <site>. Host not found".

> That's understandable. I would first try to use another browser.

I tried "elinks", thinking it would be quite different from firefox and
Epiphany, as it's a text based/terminal window browser. But alas no
joy, same problem...

> I suppose you have trouble with firefox now, so try any of the other browsers
> (dillo, konqueror, opera, ...) and if that works,

Oh, I just tried Opera, and it works !!! :-)

> reinstall firefox 

Synaptic does not allow me to re-install FF, for some reason ! The
option is greyed out ! 

> (or whatever browser you are using now).

I normally use Epiphany. I reinstalled it, but no change sadly.

> > Ah, among the sites it fails to connect to, is my e-mail
> > provider.. so I am having to write this e-mail from my Windows XP
> > virtual machine, this is agony, please help me ! ;-)
> So you can't use an email program either? 

My e-mail client (Sylpheed) fails to connect to my ISP's POP server,
( Sylpheed has a "debugging" window, where I can
see that it might be a DNS issue:

* Connecting to POP3 server:
** LibSylph-WARNING: DNS lookup failed
** LibSylph-WARNING: sock_connect_address_list_async: connection to failed
** LibSylph-WARNING: can't connect to server.
** LibSylph-WARNING: [08:32:11] Connection failed.
** Connection failed.

> Or can you only use web-mail?

I can't use the web interface for my e-mail account, because as luck
has it, the web site of my ISP happens to be part of the sites I can't
connect to !

I am not so sure if it's really DNS, because I did this experiment :

I chose a site which I can't connect to with FF/Epiphany : I opened up a terminal window to "ping" it. The ping
utility displays the IP address resolved from the host name, in this
case it reports
So, I put that IP in the address bar of FF, and despite not needing DNS
anymore in this case, well it still says it can't find the site ! 
Completely weird isn't it ?! :-/

Well at least I have now got Opera to get me going without resorting to
using a Windows VM, while we investigate the FF/epiphany/elinks


More information about the ubuntu-users mailing list