Problems with suspend on a fresh install

scar scar at
Wed Jan 28 02:21:29 UTC 2009

Hash: SHA256

Dotan Cohen @ 01/27/2009 01:11 PM:
> 2009/1/27 scar <scar at>:
>> can you please provide more details?  where to edit?  what exactly to
>> add?  i tried fiddling with this file and couldn't make any progress.
>> i am using intrepid 8.10 now though, but, still, issuing the command
>> "sudo vbetool post" indeed brings the display alive after resuming from
>> suspend/hibernate.
> What hardware are you running? It differs from hardware to hardware.
> See if something in here helps you (this is from  Dell Inspiron 6400):

this is an inspiron 1110

> $ cat /etc/default/acpi-support

at the top of my file is something extra:

SUSPEND_METHODS="dbus-pm dbus-hal pm-utils"

<snip, this is all the same>

> # Should we save and restore state using the VESA BIOS Extensions?

this line was commented out.  i uncommented it.  still no video after

<snip, this is all the same>

> # Save and restore video state?

this was uncommented.  i commented it out.  still no video after resume.

<snip, this is all the same>

> # Spindown time on battery

didn't have this line. i tried adding it.  still no video after resume.

i had this extra line at the end:

SKIP_INTERFACES="dummy qemu"

i tried commenting it out.  still no video after resume.

so, to sum up, i basically just looked thru your acpi-support file from
the top down and, when i saw a difference, i changed my own acpi-support
file.  then i shutdown the computer, restarted it, and tried suspending
and resuming.  then i moved down the rest of the file and repeated the
procedure.  so, i edited acpi-supportm shutdown, restarted, suspended,
and resumed about four times, i think.  now my acpi-support file looks
just like yours.


More information about the ubuntu-users mailing list