Problems/ Display Artifacts / Insufficient memory for Compiz (Intel 4500/g43)

David Fox dfox94085 at
Tue Jan 27 07:22:22 UTC 2009

Hello, have been a relatively long time Ubuntu user, started with
Hardy 64 on a dual core AMD64x2 last May, running an ECS Mainboard
featuring an Nvidia 6100, using the nvidia drivers.

System worked for a while but I upgraded last week to a quad core
Intel box from - featuring a5ql-em mainboard, 4g of RAM. The
mainboard supposedly has a x4500 Intel graphics adapter, but is also
labled "Q43". It also appears as "Intel Copropration Graphics Adapter
4 rev 3" in 'lspci' - I suppose that is a longer description of "Q43".

Anyway, I installed ubuntu 8.10 and updated it over the weekend. I am
having issues related to compiz and various 3D graphics applcaitions -
very similar in fact to the laptop I recently purchased, which also
uses a (mobile) Intel Graphics Adapter.

With the most recent drivers in Intrepid, I see artifacts that make it
nearly impossible to run OpenGL apps on the desktop.

When I am in KDE (kubuntu-desktop) I am using kwin's built in desktop
eye candy rather than compiz, because I cannot get compiz to run. I
start it and it complains about some GL texture not being supported,
and then the machine will lock up.

Occasionally (this happened during install) the monitor loses sync and
I have to shut down the machine.

I also have tried Sabayon 4, at 1600x1200 - my monitor is a Viewsonic
E90 - and have had a tad better graphics experience on it, but still
many GL apps refuse to run. Google Earth will complain that there is
not enough graphics memory to run the app. On ubuntu, googleearth
doesn't run at all, it starts up and then crashes.

Anyone out there with this motherboard that can help? I think I
selected the right options in the AMI BIOS to enable the card's
maximum memory. In Xorg.0.log there are lines that suggest that it has
discovered a total of 256M of video RAM. One would think that this is
enough RAM surely to run GL apps and compiz - my older system had an
onboard nvidia 6100, and at least on Intrepid, the card (also
integrated on the mainboard) worked very well.

More information about the ubuntu-users mailing list