How to run GUI admin tools remotely?

NoOp glgxg at
Sun Jan 25 20:19:15 UTC 2009

On 01/25/2009 10:19 AM, Rashkae wrote:
> Rashkae wrote:
>> Chris G wrote:
>>> I have a backup system in my garage on which I have installed xubuntu
>>> 8.10.  It would be really useful to be able to administer it remotely
>>> from my desktop system in my house (also xubuntu 8.10), but none of
>>> the GUI systems/services admin tools will work because of X security. 
>>> I always get something like the following:-
>>>     root at garage:/usr/bin# services-admin
>>>     X11 connection rejected because of wrong authentication.
>>>     (services-admin:7307): Gtk-WARNING **: cannot open display: localhost:10.0
>>> Running *user* programs remotely works fine so I have ssh running such
>>> that X is working OK.  I have also tried all sorts of 'xhosts +'
>>> commands on the local system such that there should be virtually no X
>>> authentication at all but I still get the above error.
>>> Can anyone suggest a way to do this?
>> Use sudo -s to get your root shell instead of sudo -i.  That will
>> preserver your environment variables.
> Alternatively, you can copy the .Xauthority file from the user home
> directory to your root home directory.  However, using sudo -s (or su
> -m, if you use su) will preserver the HOME environment variable, which
> will retain the correct .Xauthority

Since it's on a local lan and supposedly running a graphic desktop, why
not just use VNC via Terminal Server Client (or Krdc if it's kubuntu)?
VNC isn't hampered by the restrictions & will allow shutdown, etc. I
find that when using the NoMachine NX, which uses ssh that there are
similar issues (can't unlock, can't shutdown etc), but not with VNC.

I _think_ that you can modify the policy settings in
System|Administration|Authorizations - but everytime I've messed with
that I've screwed something up.

More information about the ubuntu-users mailing list