How to run GUI admin tools remotely?

Chris G cl at
Sun Jan 25 19:09:13 UTC 2009

On Sun, Jan 25, 2009 at 11:56:47AM -0600, Preston Kutzner wrote:
> On Jan 25, 2009, at 7:17 AM, Chris G wrote:
>> I have a backup system in my garage on which I have installed xubuntu
>> 8.10.  It would be really useful to be able to administer it remotely
>> from my desktop system in my house (also xubuntu 8.10), but none of
>> the GUI systems/services admin tools will work because of X security.
>> I always get something like the following:-
>>    root at garage:/usr/bin# services-admin
>>    X11 connection rejected because of wrong authentication.
>>    (services-admin:7307): Gtk-WARNING **: cannot open display: 
>> localhost:10.0
>> Running *user* programs remotely works fine so I have ssh running such
>> that X is working OK.  I have also tried all sorts of 'xhosts +'
>> commands on the local system such that there should be virtually no X
>> authentication at all but I still get the above error.
>> Can anyone suggest a way to do this?
> How are you connecting to the server?  Are you using SSH with the -X 
> switch?  Also, how are you trying to start the admin apps?  You should use 
> gksudo, or the KDE equivalent (depending on what is installed on the remote 
> machine) instead of just sudo.  That might be part of your problem.  I also 
> recommend using the -C switch, which compresses the data over the SSH 
> session.  I've been able to run remote admin GUI apps using X forwarding 
> over SSH over the internet without issues.

I'm only running over a local LAN so speed is not an issue.

As noted higher up in the thread I have just tried "gksu
services-admin" but the "Unlock" is greyed out so I can't actually do

> -- 
> ubuntu-users mailing list
> ubuntu-users at
> Modify settings or unsubscribe at:

Chris Green

More information about the ubuntu-users mailing list